Product Compatibility

The compatibility matrixes show which versions of plugins and products can work together.

Product Add-ons Compatibilities 

Product Compatibilities

 UPDM 2 plugin

UPDM 2 version17.0.11, 17.0.1 SP1,1 SP2117.0.2217.0.2 SP12, SP3217.0.3317.0.4, 17.0.4 SP1417.0.5518.0618.0 SP17
MagicDraw version17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
X
 
 
 
 
 
17.0.2 SP1, SP2, SP3, SP4
 
X
17.0.3, 17.0.3 SP1
 
X
17.0.4, 17.0.4 SP1, SP2
 
X
17.0.5, 17.0.5 SP1
 
X
18.0
 
X
18.0 SP1
 
X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0 X
18.0 SP1 X

1 SysML plugin 17.0.1 and SoaML profile 17.0.1 need to be installed.
2 SysML plugin 17.0.2 and SoaML profile 17.0.2 need to be installed.
3 SysML plugin 17.0.3 and SoaML profile 17.0.2 need to be installed.
4 SysML plugin 17.0.4 and SoaML profile 17.0.2 need to be installed.
5 SysML plugin 17.0.5 and SoaML profile 17.0.2 need to be installed.
6 SysML plugin 18.0 and SoaML profile 17.0.2 need to be installed.
7 SysML plugin 18.0 or 18.0 SP1 and SoaML profile 17.0.2 need to be installed.

Click here to see the UPDM 2 plugin description.

 UPDM 1 plugin

UPDM version16.5116.5 SP1116.6216.7316.8, 16.8 SP1416.9517.0, 17.0 SP1, SP2617.0 SP3617.0.17, 17.0.1 SP17, SP2717.0.28
MagicDraw version16.5, 16.5 SP1, SP2
X
X
16.5 SP3, SP4
X
16.6, 16.6 SP1, SP2
X
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3
X
17.0 SP4, SP5
X
X
17.0 SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X

Notes:

1 SysML plugin 16.5 and SoaML profile 1.0 need to be installed.
2 SysML plugin 16.6 and SoaML profile 2.0 need to be installed.
3 SysML plugin 16.6 with or without service pack (recommended with SP2) and SoaML profile 16.6 need to be installed.
4 SysML plugin 16.8 and SoaML profile 16.8 need to be installed.
5 SysML plugin 16.9 and SoaML profile 16.9 need to be installed.
6 SysML plugin 17.0 or later version and SoaML profile 16.9 need to be installed.
7 SysML plugin 17.0.1 or later version and SoaML profile 17.0.1 need to be installed.
8 SysML plugin 17.0.2 or later version and SoaML profile 17.0.2 need to be installed.

Click here to see the UPDM plugin description.

 SysML plugin

SysML version16.816.9,
16.9 SP1
17.0,
17.0 SP1, SP2
17.0 SP3, SP4,
SP5, SP6
17.0 SP717.0.117.0.1 SP117.0.1 SP217.0.217.0.2 SP1, SP3, SP417.0.3, 17.0.3 SP117.0.417.0.5, 17.0.5 SP118.0118.0 SP11
MagicDraw
version
16.8 X
16.9
X
17.0, 17.0 SP1, SP2
X
17.0 SP3, SP4, SP5
X
X*
17.0 SP6 X
17.0.1
X
17.0.1 SP1
X
17.0.1 SP2
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0 X X
18.0 SP1 X

Notes:

* SysML 17.0 SP7 is compatible with MagicDraw version 17.0 SP3 and SP5, but not compatible with MagicDraw 17.0 SP4.
1 Cameo Requirements Modeling plugin 18.0 and Document Modeling plugin 18.0 or 18.0 SP1 need to be installed.

Click here to see the SysML plugin description.

 Cameo Simulation Toolkit

Cameo Simulation Toolkit version1.0, 1.0 SP117.0.117.0.1 SP117.0.217.0.2 SP1, SP3, SP417.0.317.0.4, 17.0.4 SP1, SP217.0.5, 17.0.5 SP118.018.0 SP1
MagicDraw version16.9
X
X
X
17.0, 17.0 SP1, SP2
X
 
 
 
17.0 SP3, SP4, SP5, SP6
X
X
X
17.0 SP6 X
17.0.1, 17.0.1 SP1, SP2
X
X
X
17.0.1 SP2
 
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X X X X
17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X X X
17.0.5, 17.0.5 SP1 X X X
18.0 X
18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2
X
 
 
 
17.0 SP3, SP4, SP5, SP6
X
X
X
17.0 SP6 X
17.0.1, 17.0.1 SP1, SP2
X
X
X
17.0.1 SP2 X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X X X X
17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X X X
17.0.5, 17.0.5 SP1 X X X
18.0 X
18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X X X
17.0.5, 17.0.5 SP1 X X X
18.0 X
18.0 SP1 X

Click here to see the Cameo Simulation Toolkit description.

 

Cameo Requirements Modeler

Cameo Requirements Modeler18.0
MagicDraw version18.0, 18.0 SP1 X
Cameo Enterprise Architecture version18.0, 18.0 SP1 X
Cameo Systems Modeler version18.0, 18.0 SP1 X

 

 Cameo DataHub

Cameo DataHub version22.12.52.5 SP133.0 SP13.0 SP244.0 SP14.14.1 SP14.1 SP24.1 SP317.0.117.0.1 SP117.0.1 SP217.0.1 SP317.0.1 SP417.0.217.0.2 SP1, SP217.0.3, 17.0.3 SP117.0.417.0.5, 17.0.5 SP118.0
IBM Rational
DOORS version
8 X X X X X X X X X X X X X X X X X X X X X X X
8.1 X X X X X X X X X X X X X X X X X X X X
8.2 X X X X X X X X X X X X X X X X X X X X
8.3 X X X X X X X X X X X X X X X X X X X X X
9 X X X X X X X X X X X X X X X X X X X X X
9.1 X X X X X X X X X X X X X X X
9.2 X X X X X X X X X X X X X X X
9.3 X X X X X X X X X X X
9.4 X X X X X
9.5 X X X X X X
MagicDraw
version
15.5 X
16 X X X
16.5 X X X
16.5 SP1 X X
16.5 SP2, SP3, SP4 X
16.6, 16.6 SP1, SP2 X X X
16.8 X X
16.9 X X X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X X X X
17.0.1 X X X X X
17.0.1 SP1, SP2 X X X X
17.0.2 X X X
17.0.2 SP1, SP2, SP3, SP4 X X X X X X
17.0.3, 17.0.3 SP1 X X X X X
17.0.4, 17.0.4 SP1, SP2 X X X
17.0.5, 17.0.5 SP1 X X X
18.0, 18.0 SP1 X
Cameo Enterprise
Architecture version
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X X X X
17.0.1 X X X X
17.0.1 SP1, SP2 X X X
17.0.2 X X X
17.0.2 SP1, SP2, SP3, SP4 X X X X X X
17.0.3, 17.0.3 SP1 X X X X X
17.0.4, 17.0.4 SP1, SP2 X X X
17.0.5, 17.0.5 SP1 X X X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.1 SP1, SP2 X X X
17.0.2 X X X
17.0.2 SP1, SP2, SP3, SP4 X X X X X
17.0.3, 17.0.3 SP1 X X X X
17.0.4, 17.0.4 SP1, SP2 X X
Cameo
Requirements
+version
2 X X X X
3.0, 3.0 SP1 X X X
4 X X
4.1 X
4.1 SP1 X
4.1 SP2 X X X X
4.1 SP3 X X X X X X X X X
Rational
RequisitePro version
7 X X X X X X X X X X X X X X X X X X X X X X X X

Note: DataHub includes pre-defined mapping templates which allow users to export data between MagicDraw with SysML plugin, Cameo Requirements+, Rational RequisitePro, and IBM Rational DOORS. Other MagicDraw profiles are also supported including CBM, UPDM DoDAF, and any custom profile.

Click here to see the Cameo DataHub description.

 

 Cameo Inter-Op and Cameo Workbench

Cameo Inter-Op and Cameo Workbench version1.01.0.11.0.21.0.317.0.1, 17.0.1 SP1,SP217.0.217.0.2 SP117.0.317.0.4, 17.0.4 SP118.0
MagicDraw version16.6
X
X
X
X
16.8
X
X
X
X
16.9
X
X
X
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
X
X
X
X
 
17.0.2 SP1, SP2, SP3, SP4
X
X
X
X
 
17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
X
X
X
X
 
17.0.2 SP1, SP2, SP3, SP4
X
X
X
X
 
17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo Business Modeler version17.0.1 SP1, SP2 X
17.0.2 X X X X X
17.0.2 SP1, SP2, SP3, SP4 X X X X
17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo E2E Builder version17.0 X X X X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X

 

Note: In order to exchange data with System Architect, UPDM plugin needs to be installed.

Click here to see the Cameo Inter-Op description.
Click here to see the Cameo Workbench description.

 

 Cameo SOA+ plugin

Cameo SOA+ version16.0 beta 116.5116.5 SP1116.5 SP2116.6216.8316.9417.04
17.0.15
17.0.26
17.0.36
17.0.46
17.0.56
MagicDraw version16.0
X
16.5, 16.5 SP1
X
X
16.5 SP2
X
16.5 SP3, SP4
X
16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Notes:
1 SoaML profile 1.0 need to be installed.
2 SoaML profile 16.6 need to be installed.
3 SoaML profile 16.8 need to be installed.
4 SoaML profile 16.9 need to be installed.
5 SoaML profile 17.0.1 need to be installed.
   The integration with  ModelPro from ModelDriven.org is not supported.
6 SoaML profile 17.0.2 need to be installed.
   The integration with  ModelPro from ModelDriven.org is not supported.

Click here to see the Cameo SOA+ plugin description.

 Cameo Data Modeler plugin

Cameo Data Modeler version16.516.5 SP116.616.8
17.0.1
17.0.1 SP1
17.0.2, 17.0.2 SP3
17.0.3
17.0.4, 17.0.4 SP2
17.0.5
18.0
18.0.1
MagicDraw version16.5, 16.5 SP1, SP2
X
16.5 SP3, SP4
X
16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1
X
X
17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1
X
X
17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP2. SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X

Note: Cameo Data Modeler plugin replaces previous (no-cost) Data Modeling Notations plugin.

Click here to see the Cameo Data Modeler plugin description.

 Cameo Business Modeler plugin

Cameo Business Modeler plugin version16.8 alpha16.816.917.0, 17.0 SP1, SP217.0.117.0.1 SP117.0.1 SP217.0.217.0.2 SP117.0.2 SP317.0.3, 17.0.3 SP117.0.417.0.518.018.0 SP1
MagicDraw version16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1
X
17.0.1 SP1, SP2
X
X
X
17.0.2
X
X
17.0.2 SP1, SP2 X
17.0.2 SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Note: Cameo Business Modeler plugin replaces the non-cost Business Process diagram in MagicDraw.

Click here to see the Cameo Business Modeler plugin description.

Cameo E2E Builder Plugin

Cameo E2E builder Plugin version18.0
MagicDraw version18.0, 18.0 SP1 X
Cameo Enterprise Architecture version18.0, 18.0 SP1 X
Cameo Business Modeler version18.0, 18.0 SP1 X
Cameo Systems Modeler version18.0, 18.0 SP1 X

 

Performance Measurement plugin

Performance Measurement plugin version17.0.1
MagicDraw version17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

 QVT plugin

QVT plugin version17.0.117.0.217.0.418.0
MagicDraw version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
 
X
17.0.5, 17.0.5 SP1
 
X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
 
X
17.0.5, 17.0.5 SP1
 
X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X

Click here to see the QVT plugin description.

 

Resource Builder plugin

Resource Builder plugin version16.9
MagicDraw version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1  X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1  X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1  X

 

RM-ODP plugin

RM-ODP plugin version1.0.0
MagicDraw version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

 TOGAF plugin

TOGAF plugin version17.0, 17.0 SP117.0.117.0.217.0.418.0
MagicDraw version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
 
X
17.0.5, 17.0.5 SP1
 
X
18.0, 18.0 SP1
 
X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X  
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1   X

Click here to see the TOGAF plugin description.

 Project Merge plugin

Project Merge plugin comes out with every new version of MagicDraw.

Click here to see the Project Merge plugin description.

 Cameo MDA plugin

Cameo MDA version16.816.9
MagicDraw version16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the Cameo MDA plugin description.

 MagicRQ plugin

MagicRQ version1.01.12.014.015.015.0 SP216.0, 16.0 SP1, SP2, SP3, SP4, SP516.5, 16.5 SP1, SP2, SP316.616.6 SP1
MagicDraw version12.0
X
X
X
X
12.1
X
X
X
X
12.5
X
X
X
X
14.0
X
X
X
X
15.0
X
X
15.1
X
X
15.5
X
16.0
X
16.5, 16.5 SP1, SP2, SP3, SP4
X
16.6, 16.6 SP1, SP2
X
X
16.8
X
X
16.9
X
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
IBM Rational RequisitePro 7.0/2003
X
X
X
X
X
X
X
X
X
X
Rational Doors version8.0
X
X
X
X
X
X
X
8.1
X
X
X
X
8.2
X
X
X
X
8.3
X
X
X
X
9.0
X
X
X
X

Click here to see the MagicRQ plugin description.

 MagicDraw RSXConverter

This is stand-alone converter, not a plugin.

MagicDraw RSXConverter version1.0 SP3
MagicDraw version16.6
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
IBM Rational Software Modeler/Architect7.0
X
7.5
X
8.0*
X
Cameo Business Modeler version17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X

Note: Compatibility with IBM Rational Software Modeler/Architect 8.0 bases on available element exist in RSM/RSA 7.5.

Click here to see the MagicDraw RSXConverter description.

 MagicDraw RConverter

This is stand-alone converter, not a plugin.

MagicDraw RConverter version1.4
MagicDraw version9.0, 9.0 SP1, SP2
X
9.5, 9.5 SP1
X
10.0
X
10.5
X
11.0
X
11.5
X
11.6
X
12.0
X
12.1
X
12.5
X
14.0
X
15.0
X
15.1
X
15.5
X
16.0
X
16.5
X
16.6
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Business Modeler version17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the MagicDraw RConverter description.

 ParaMagic plugin

ParaMagic version15.5116.0216.5416.6416.6 SP1516.8516.9517.0617.0.1717.0.2718.0 beta
MagicDraw + SysML version15.5
X
16.0
X
X
16.5, 16.5 SP1, SP2
X3
X
16.5, SP3, SP4
X3
X
X
16.6, 16.6 SP1
X
X
X
X
16.6 SP2
X
X
X
X
X
16.8
X
X
X
X
X
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X  
17.0.3, 17.0.3 SP1 X  
17.0.4, 17.0.4 SP1, SP2 X  
17.0.5, 17.0.5 SP1 X X
18.0   X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0 X

Notes:

SysML plugin needs to be installed.
--To work properly with ParaMagic on Mac OS, try to use Java SDK 1.6 instead of Java 1.5. For 32-bit Mac OS, use SoyLatte JDK (see Users Guide for details).
ParaMagic™ requires Mathematica for math solving.

1 tested with Mathematica versions 5.2 and 6.0
2 tested with Mathematica versions 5.2, 6.0 and 7.0
3 Paramagic 15.5 may work with MagicDraw + SysML 16.5. However, we do not suggest using them together since untested.
4 tested with Mathematica versions 6.0 and 7.0. Mathematica 5.2 is not supported anymore.
5 tested with Mathematica version 7.0
6 For core solver, ParaMagic requires either Mathematica 8.0, OpenModelica 1.7.0, or MATLAB Symbolic Math Toolbox R2010b. Mathematica 7.0 and OpenModelica 1.5 are not supported.
7 A core solver is required, either Mathematica 8.0, OpenModelica 1.7 or 1.8, or MATLAB Symbolic Math Toolbox R2010b. Simulink® R2010b and MS Excel® 2003, 2007, 2010 are optional.

Click here to see the ParaMagic plugin description.

 ParaMagic Lite plugin

ParaMagic Lite version16.8116.9117.0217.0.1317.0.2318.0 beta
MagicDraw + SysML version16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2
X
17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0 X

Notes:

SysML plugin needs to be installed.
1 tested with Mathematica version 7.0
2 For core solver, it requires either Mathematica 8.0, OpenModelica 1.7.0, or MATLAB Symbolic Math Toolbox R2010b. Mathematica 7.0 and OpenModelica 1.5 are not supported
3 A core solver is required, either Mathematica 8.0, OpenModelica 1.7 or 1.8, or MATLAB Symbolic Math Toolbox R2010b. Simulink® R2010b and MS Excel® 2003, 2007, 2010 are optional.

 Methodology Wizards plugin

Methodology Wizards version15.516.016.516.616.817.0
17.0.1, 17.0.1 SP1
17.0.2
17.0.3
17.0.4
17.0.5
18.0
MagicDraw version15.5
X
16.0
X
16.5, 16.5 SP1, SP2
X
16.5, SP3, SP4
X
16.6
X
16.6 SP1, 16.6 SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the Methodology Wizards plugin description.

 SPEM 2.0 plugin

SPEM 2.0 version16.8
MagicDraw version15.0
X
15.1
X
15.5
X
16.0
X
16.5, 16.5 SP1, SP2, SP3, SP4
X
16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the SPEM 2.0 plugin description.

 DoDAF plugin

MagicDraw version12.012.112.514.015.015.115.516.016.516.5 SP116.5 SP216.5 SP3, SP416.6, 16.6 SP1, SP216.16.9
DoDAF version2.0
X
X
X
X
2.1
X
X
15.0
X
X
15.5
X
16.0
X
16.5
X
16.5 SP1
X
X
16.5 SP2
X
X
X
16.5 SP3
X
16.6
X
16.8
X
16.9
X

Note: SysML plugin needs to be installed.
Click here to see the DoDAF plugin description.

 CSV Import plugin

CSV Import version17.0.2 SP4, SP5*17.0.2 SP618.0
MagicDraw version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
X
18.0, 18.0 SP1
 
X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
X
18.0, 18.0 SP1
 
X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X

* Due to technical issues, only CSV Import plugin 17.0.2 SP4 and later versions are available.

Click here to see the CSV Import plugin description.

 

Excel Import plugin

Excel Import plugin version17.0.4 beta18.0
MagicDraw version17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

 Enterprise Architect Import plugin

Enterprise Architect Import plugin version17.0.1, 17.0.1 SP1, SP217.0.2, 17.0.2 SP1, SP2, SP317.0.3, 17.0.3 SP117.0.4
MagicDraw version

17.0.1, 17.0.1 SP1, SP2

X
X
X
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
 
X
X
X
17.0.3, 17.0.3 SP1
 
X
X
X
17.0.4, 17.0.4 SP1, SP2
 
 
X
17.0.5, 17.0.5 SP1
 
 
X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version

17.0.1, 17.0.1 SP1, SP2

X X X X

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X X X

17.0.3, 17.0.3 SP1

X X X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X
Cameo Business Modeler version

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X X X

17.0.3, 17.0.3 SP1

X X X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X
Cameo Systems Modeler version

17.0.3, 17.0.3 SP1

X X X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X

 


 CPU & Memory Profiler plugin

CPU & Memory Profiler plugin version17.0
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X

17.0.1, 17.0.1 SP1, SP2

X

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X

17.0.3, 17.0.3 SP1

X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X
Cameo Business Modeler version

 

 

 

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X

17.0.3, 17.0.3 SP1

X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X
Caemo E2E Builder version

17.0

X
Cameo Systems Modeler version

17.0.3, 17.0.3 SP1

X

17.0.4, 17.0.4 SP1, SP2

X

17.0.5, 17.0.5 SP1

X

18.0, 18.0 SP1

X


 Strict UML XMI Exporter plugin

Strict UML XMI Exporter plugin version17.017.0 SP117.0 SP2
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
X
X
17.0.1, 17.0.1 SP1, SP2
X
X
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
X
X
17.0.3, 17.0.3 SP1
X
X
X
17.0.4, 17.0.4 SP1, SP2
 
X
X
17.0.5, 17.0.5 SP1
 
X
X
18.0, 18.0 SP1
X
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X X X
17.0.1, 17.0.1 SP1, SP2 X X X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X X X
17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X X X
17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X X
Cameo E2E builder version17.0 X X X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X X

 

 Model Obfuscator plugin

Model Obfuscator plugin version17.017.0.217.0.5
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
 
X
 
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
 
X
 
17.0.3, 17.0.3 SP1
X
 
17.0.4, 17.0.4 SP1, SP2
X
 
17.0.5, 17.0.5 SP1
 
X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X




Cameo eWork

Cameo eWork version17.0.2 beta17.0.4
MagicDraw and/or Teamwork version

17.0.2

X
 

17.0.2 SP1, SP2, SP3, SP4

X
X

17.0.3, 17.0.3 SP1

X
X

17.0.4, 17.0.4 SP1, SP2

 
X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture and/or Teamwork version17.0.2 X
17.0.2 SP1, SP2, SP3, SP4 X X
17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2 X
17.0.2 SP1, SP2, SP3, SP4 X X
17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

Zachman Framework  plugin

Zachman Framework plugin version17.0.217.0.4
MagicDraw version

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X

17.0.3, 17.0.3 SP1

X

17.0.4, 17.0.4 SP1, SP2

 
X

17.0.5, 17.0.5 SP1

 
X

18.0, 18.0 SP1

X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X


Other Product Compatibilities

 Cameo Requirements+

Cameo Requirements+ version2.03.0, 3.0 SP14.04.0 SP14.14.1 SP14.1 SP24.1 SP3
Cameo DataHub version2.0
X
2.1
X
2.5, 2.5 SP1
X
3.0, 3.0 SP1, SP2
X
4.0, 4.0 SP1
X
X
4.1
X
4.1 SP1
X
4.1 SP2, SP3
X
17.0.1
X
17.0.1 SP1
X
17.0.1 SP2, SP3, SP4
X
17.0.2, 17.0.2 SP1, SP2
X
17.0.3, 17.0.3 SP1
X
17.0.4
X
17.0.5, 17.0.5 SP1
X
18.0
X
Cameo Team Server version4.0
X
4.0 SP1
X
4.1
X
X
X

Click here to see the Cameo Requirements+ description.

 Floating License Server Compatibilities

As of v12.0, the version of the Floating License Server can differ from the client version. You do not need to reinstall Floating License Server, you only need to change Floating License Server unlock key.

As of v16.8, FlexNet license server is used to manager floating licenses. FlexNet License Server is compatible with v16.8 (and later) client applications. In order to use v16.6 and v16.8 floating licenses simultaneously, both No Magic Floating Server and FlexNet License Server installations are needed.

 

Product Add-ons Compatibilities

 Teamwork Server

Teamwork Server version16.516.5 SP116.616.6 SP116.816.917.0, 17.0 SP1, SP2, SP417.0.1, 17.0.1 SP117.0.1 SP217.0.2,17.0.2 SP1, SP3, SP417.0.3, 17.0.3 SP117.0.4, 17.0.4 SP117.0.5, 17.0.5 SP118.0, 18.0 SP1
MagicDraw version16.5
X
16.5 SP1, SP2, SP3, SP4
X
X
16.6
X
16.6 SP1, SP2
X
X
16.8
X
16.9
X
17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1
X
X
17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X X X
17.0.5, 17.0.5 SP1 X X X
18.0, 18.0 SP1 X X X
Cameo Enterprise Architecture version17.0, SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1
X
X
17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
 
 
 
 
17.0.3, 17.0.3 SP1
 
X
17.0.4, 17.0.4 SP1, SP2
 
X X X
17.0.5, 17.0.5 SP1
 
X X X
18.0, 18.0 SP1
 
X X X
Cameo Business Modeler Analyst/Architect version17.0.1 SP1
X
X
17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
 
X
17.0.3, 17.0.3 SP1
 
X
17.0.4, 17.0.4 SP1, SP2
 
X X X
17.0.5, 17.0.5 SP1
 
X X X
18.0, 18.0 SP1
 
X X X
Cameo E2E Builder version17.0 X
 
Cameo Systems Modeler version17.0.3, 17.0.3 SP1
 
X
17.0.4, 17.0.4 SP1, SP2
 
X X X
17.0.5, 17.0.5 SP1
 
X X X
18.0, 18.0 AP1
 
X X X

Note: Teamwork Server version must be the same as MagicDraw and Cameo Enterprise Architecture otherwise they will not be able to connect to the server.

Click here to see the Teamwork Server description.

 Third Party Product Compatibilities

 Cameo OCL Transformer plugin

Cameo OCL Transformer version1.02.0 2.0 SP1
MagicDraw version16.5
X
16.6
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2 X X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2 X X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the Cameo OCL Transformer plugin description.

 Cameo XSD Import plugin

Cameo XSD Import version1.11.41.5 SP11.5 SP21.5 SP3
MagicDraw version16.5
X
 
16.6
X
 
16.8
X
X
X
16.9
X
X
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
X
17.0.1, 17.0.1 SP1, SP2
X
X
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
X
X
17.0.1, 17.0.1 SP1, SP2
X
X
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

Click here to see the Cameo XSD Import plugin description.

 Nomos OCL Export plugin

Nomos OCL Export version1.4
MagicDraw version16.5
X
16.6
X
16.8
X
16.9
X


 Cameo NIEM-UML plugin

Cameo NIEM-UML plugin17.0.2 SP118.0, 18.0 SP1
MagicDraw version17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1 X

 

Intel Cofluent Studio Plugin

Intel Cofluent Studio Plugin version2.0
MagicDraw version17.0.5 X
Cameo Enterprise Architecture version17.0.5 X
Cameo Systems Modeler version17.0.5 X

 

 CoFluent plugin

CoFluent version1.01.1
MagicDraw version16.5
X
X
16.6
X
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5
X


Note: MARTE profile needs to be installed.

 EstimIX plugin

EstimIX version16.6
MagicDraw version16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X

 ExtendIX plugin

ExtendIX version16.6
MagicDraw version16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X

 SYSMOD plugin

SYSMOD version17.0.117.0.2
MagicDraw + SysML version17.0.1 SP2
X
X
17.0.2
X
17.0.2 SP1, SP3, SP4
X
X
17.0.3, 17.0.3 SP1
X
X
17.0.4, 17.0.4 SP1, SP2
X
X
17.0.5, 17.0.5 SP1
X
X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X X
17.0.4, 17.0.4 SP1, SP2 X X
17.0.5, 17.0.5 SP1 X X
18.0, 18.0 SP1 X


Note: For SysML version 17.0.1 and 17.0.1 SP1, the SYSMOD profile is integrated into the SysML plugin.


Testing Profile plugin

Testing profile plugin version16.917.0.218.0
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
 
17.0.1, 17.0.1 SP1, SP2
X
 
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
 
X
17.0.3, 17.0.3 SP1
 
X
17.0.4, 17.0.4 SP1, SP2
 
X
17.0.5, 17.0.5 SP1
 
X
18.0, 18.0 SP1
 
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X


 
FAS plugin

FAS version17.0.1
MagicDraw + SysML version17.0.1 SP2
X
17.0.2, 17.0.2 SP1, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 VeTIS plugin

VeTIS version1.01.1
MagicDraw version16.0
X
16.5, 16.5 SP1, SP2, SP3, SP4
X
16.6, 16.6 SP1, SP2
X
16.8
X
16.9
X
17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6
X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

J2ME - Java Wireless Toolkit 2.5 profile 

J2ME - Javas Wireless Toolkit 2.5 profile version16.6
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
 18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

MARTE 1.0 profile

MARTE 1.0 profile version16.9
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X


MARTE 1.1 profile

MARTE 1.1 profile version17.0
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 


SoaML profile

SoaML profile version17.0.2
MagicDraw version

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

SPEM profile

SPEM profile version16.6
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X



DSL sample

DSL sample version16.6
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X



Information System for Training Organization sample

Information System for Training Organization sample version17.0.218.0
MagicDraw version

17.0.2, 17.0.2 SP1, SP2, SP3, SP4

X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1 X
Cameo Enterprise Architecture version17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 

Document Modeling plugin

Document Modeling plugin version18.0, 18.0 SP1
MagicDraw version18.0, 18.0 SP1 X
Cameo Enterprise Architecture version18.0, 18.0 SP1 X
Cameo Systems Modeler version18.0, 18.0 SP1 X



UML2 Meta Model with attributes sample

UML2 Meta Model with attributes sample version2.42.5
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X X


Working with modules sample

Working with modules sample version1.1
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo Business Modeler version17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X
Cameo E2E Builder version17.0 X
Cameo Systems Modeler version17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 


GNU common C++ template

GNU common C++ template version1.1
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 


MFC template

MFC template version2.1
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

 


JAVA SE 7 Library

JAVA SE 7 Library version1.0
MagicDraw version

17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6

X
17.0.1, 17.0.1 SP1, SP2
X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4
X
17.0.3, 17.0.3 SP1
X
17.0.4, 17.0.4 SP1, SP2
X
17.0.5, 17.0.5 SP1
X
18.0, 18.0 SP1
X
Cameo Enterprise Architecture version17.0, 17.0 SP1, SP2, SP3, SP4, SP5, SP6 X
17.0.1, 17.0.1 SP1, SP2 X
17.0.2, 17.0.2 SP1, SP2, SP3, SP4 X
17.0.3, 17.0.3 SP1 X
17.0.4, 17.0.4 SP1, SP2 X
17.0.5, 17.0.5 SP1 X
18.0, 18.0 SP1 X

omg-member-logo

nomagic gartner-ad 2013

facebook 32 linkedin 32 twitter 32 youtube 32 rss 32