18.1

user guide
## CONTENTS

### 1 GETTING STARTED 8

1.1 Introducing Cameo DataHub 8  
1.2 System Requirements 9  
1.3 Licensing 9  
1.4 Changelog 9  
1.5 Installation 10  
  1.5.1 Uninstallation 11  
1.6 Upgrading from previous versions of DataHub 11  
1.7 Migrating DataHub data from previous versions of DataHub 11  
1.8 Running DataHub 12

### 2 UNDERSTANDING DATAHUB USER INTERFACE 13

2.1 DataHub Menu 13  
  2.1.1 Hot Keys 17  
2.2 DataHub Explorer Tab 18  
  2.2.1 DataHub Operations drop-down 19  
    2.2.1.1 Copy Data 20  
    2.2.1.2 Copy Data with Sync 20  
    2.2.1.3 Create OSLC Link 20  
  2.2.2 DataHub Tree 20  
  2.2.3 DataHub Explorer Buttons and Icons 20  
2.3 DataHub Properties Tab 22  
2.4 DHLink Panel 23  
  2.4.1 Context Menu 24  
2.5 DataHub Alias 26  
  2.5.1 Alias Manager 26  
2.6 Data Sources 27  
2.7 Schema Map and Mapping Options 27  
  2.7.1 Individual Type Mapping 27  
  2.7.2 Group Type Mapping 28  
  2.7.3 Define Target Type from Attribute Value Mapping 28  
  2.7.4 Schema Map Manager 28  
  2.7.5 Schema Map Templates 28  
2.8 Driver Deployment 28  
2.9 Prepare Data For Module 29
## CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.10 NEW! OSLC Support</td>
<td>29</td>
</tr>
<tr>
<td>2.11 NEW! Add-on Features</td>
<td>30</td>
</tr>
<tr>
<td>2.11.1 Conflict Dashboard</td>
<td>30</td>
</tr>
<tr>
<td>2.11.2 Components of Conflict Dashboard</td>
<td>31</td>
</tr>
<tr>
<td>2.11.2.1 Display drop-down</td>
<td>31</td>
</tr>
<tr>
<td>2.11.2.2 Properties Panel</td>
<td>31</td>
</tr>
<tr>
<td>2.11.2.3 Node Changes</td>
<td>32</td>
</tr>
<tr>
<td>2.11.3 Text Search in DataHub Explorer and Alias Manager</td>
<td>32</td>
</tr>
<tr>
<td>2.11.4 Inactive Data Source Filter</td>
<td>33</td>
</tr>
<tr>
<td>2.11.5 Data Copy Progress Bar</td>
<td>33</td>
</tr>
<tr>
<td>3 WORKING WITH DATAHUB IN MAGICDRAW</td>
<td>34</td>
</tr>
<tr>
<td>3.1 Customizing DataHub Options</td>
<td>34</td>
</tr>
<tr>
<td>3.1.1 General</td>
<td>35</td>
</tr>
<tr>
<td>3.1.2 Confirmation</td>
<td>37</td>
</tr>
<tr>
<td>3.2 Working with the DataHub Explorer tree</td>
<td>40</td>
</tr>
<tr>
<td>3.2.1 Working with Data Sources</td>
<td>40</td>
</tr>
<tr>
<td>3.2.1.1 Adding a CSV Data Source</td>
<td>40</td>
</tr>
<tr>
<td>3.2.1.2 Adding an IBM® Rational® DOORS® Data Source</td>
<td>42</td>
</tr>
<tr>
<td>3.2.1.3 Adding an IBM® Rational® DOORS® Next Generation Data Source</td>
<td>43</td>
</tr>
<tr>
<td>3.2.1.4 Display a MagicDraw® Data Source</td>
<td>43</td>
</tr>
<tr>
<td>3.2.2 Closing and opening Data Sources</td>
<td>44</td>
</tr>
<tr>
<td>3.2.3 Filtering Inactive Data Sources</td>
<td>45</td>
</tr>
<tr>
<td>3.2.4 Removing a Data Source</td>
<td>45</td>
</tr>
<tr>
<td>3.3 Adding a New Node to Data Source</td>
<td>45</td>
</tr>
<tr>
<td>3.4 Searching for a text string</td>
<td>48</td>
</tr>
<tr>
<td>3.5 Deleting Requirements</td>
<td>49</td>
</tr>
<tr>
<td>3.6 Working with OSLC Query and OSLC Link</td>
<td>49</td>
</tr>
<tr>
<td>3.6.1 Creating OSLC Links</td>
<td>49</td>
</tr>
<tr>
<td>3.6.2 Create OSLC Query</td>
<td>51</td>
</tr>
<tr>
<td>3.6.3 Copying OSLC Query Results</td>
<td>54</td>
</tr>
<tr>
<td>3.6.3.1 Copy OSLC Query Results to MagicDraw® as SysML Requirements</td>
<td>54</td>
</tr>
<tr>
<td>(with Diagrams)</td>
<td>54</td>
</tr>
<tr>
<td>3.7 Creating Links between Elements</td>
<td>56</td>
</tr>
<tr>
<td>3.7.1 Creating DataHub Links</td>
<td>56</td>
</tr>
<tr>
<td>3.7.1.1 Copy Data with Sync</td>
<td>56</td>
</tr>
</tbody>
</table>
3.7.2 Removing Links  60
3.7.2.1 Navigate Selected Requirements in the DataHub Explorer/ Alias Explorer 61
3.7.2.2 Opening Selected Requirements in the Other Application’s Tree 62

3.8 Copying Requirements  63
3.8.1 Copying Data  64
3.8.1.1 Copy Data 65
3.8.1.2 Copy Data with Sync 69
3.8.2 Copying Requirements into MagicDraw®  81
3.8.2.1 Copying Requirements to MagicDraw® as SysML Requirement Diagram 81
3.8.2.2 Copying Requirements to MagicDraw® as Use Case Diagram 84
3.8.2.3 Copying Requirements to MagicDraw® with DataHub Link 88
3.8.2.4 Copying Requirements to MagicDraw® with OSLC Link 90

3.9 Synchronizing Requirements  92
3.9.1 Data Source Synchronization  94
3.9.2 Node Synchronization  95
3.9.3 Conflict Dashboard  97
3.9.3.1 Comparing Conflicted Requirements 98
3.9.3.2 Synchronization Status 98
3.9.4 Directions of Synchronization  98

3.10 Mapping Requirements  99
3.10.1 Mapping with the Schema Map Manager 99
3.10.2 Schema Mapping Modes  101
3.10.2.1 Simple Schema Mapping 101
3.10.2.2 Define Target Type from Attribute Value Mapping 105
3.10.3 Exporting a Schema Map  107
3.10.4 Importing a Schema Map  110
3.10.5 Deleting a Schema Map  110

3.11 Working with Alias  111
3.11.1 Alias Explorer  112
3.11.2 Alias Manager  112

3.12 Working with DHLink Summary and Generating Report  114
3.12.1 DHLink Summary  114
3.12.2 Direction of DHLink  116
3.12.3 DHLink Summary Dialog Context Menu  116
3.12.4 Saving DHLink Summary as Report  117
CONTENTS

Link 134
Recursively 134
Synchronized 134
Excluded 135
Orphan 135
PendingDelete 135
PendingUpdate 135
Sync Relation 135
Synchronized 136
Schema Map 136
Mapping Mode 136
Status 136
Unidirectional 137
1 GETTING STARTED

This user guide is intended to serve as an introduction to the Cameo DataHub features and functionality and how to use it to work with requirement management tools such as IBM® Rational® DOORS® and IBM® Rational® DOORS® Next Generation. This user guide also contains examples of how to use the DataHub features of copying data, linking, and synchronization. You will be able to copy requirements, link them to one another, as well as link them to system design models such as Use Cases, artifacts, and test cases.

Additionally, the DataHub also supports working with requirements in a collaborative context by providing data sharing among team members via Teamwork Server.

This user guide is an introduction to the UI components of DataHub and some of its features. The last section of this user guide provides the definitions of the terms used in the DataHub context.

The features of the plug-in that are explained in this user guide includes: UI interface, copy features, OSLC link and query, and DataHub configuration elements.

1.1 Introducing Cameo DataHub

DataHub for MagicDraw® and IBM® Rational® DOORS® and IBM® Rational® DOORS® Next Generation 4.x or later is a complete solution that enables you to copy and synchronize requirements, link them to one another, as well as link MagicDraw’s model elements such as SysML Requirements or Use Cases. It allows you to create relations or links between requirements and SysML use cases and test cases and makes it possible to maintain these links or relations, and update them using bidirectional or unidirectional synchronization capabilities. Additionally, you could also transfer requirements to and from CSV file repositories.

Cameo DataHub uses OSLC (Open Services for Lifecycle Collaboration) specifications for data integration and tools collaboration. OSLC is an open community developing a set of specifications for integrating tools. OSLC enables independent software and product lifecycle tools to interact and integrate their requirements via links between related resources. DataHub allows the user to access requirements from IBM® Rational® DOORS® or IBM® Rational® DOORS® Next Generation and copy them to MagicDraw® as SysML requirements or Use Cases using a mapping mechanism, where the source and target elements are defined. DataHub enables you to link your requirements to the other requirement management tools such as MagicDraw®, IBM® Rational® DOORS® 8.0-8.3 and 9.0-9.5 versions, and IBM® Rational® DOORS® Next Generation for more effective automation, communication, and collaboration.

The current release of Cameo DataHub is loaded with improvements and important capabilities such as OSLC integration support, that focus on interoperability between tools to improve traceability and consistency of data across the organization.

Support for Cameo Requirements+ and IBM® Rational® RequisitePro® has been removed and replaced by even more dedicated support for IBM® Rational® DOORS®, IBM Rational® DOORS® Next Generation, and CSV files.

DataHub plug-in works with the following requirements management tools:

- MagicDraw® (MagicDraw® with SysML, and UPDM plug-in 18.0 or later)
- IBM® Rational® DOORS® (8.0-8.3 and 9.0-9.5)
- IBM® Rational® DOORS® Next Generation 4.x or later
- CSV file repositories
DataHub supports almost all types of MagicDraw® model elements and diagrams.

## 1.2 System Requirements

### Table 1 -- System Requirements

<table>
<thead>
<tr>
<th>Resource</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Pentium™ 4, 1.6 GHz or higher</td>
<td>Core™ i3, 2.5 GHz or higher</td>
</tr>
<tr>
<td>Memory</td>
<td>2GB of RAM</td>
<td>• 3GB of RAM. Higher memory capacity generally improves responsiveness.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 4GB of RAM is recommended for very large projects.</td>
</tr>
<tr>
<td>Disk space</td>
<td>400MB</td>
<td>400MB or more</td>
</tr>
<tr>
<td>Video mode</td>
<td>800x600 @ 64k colors</td>
<td>1280x1024 @ 64k colors</td>
</tr>
<tr>
<td>Operating Systems</td>
<td>• All that support Java compatible JVM 1.6.</td>
<td>• Windows XP SP3, Windows Vista, Windows 7, Window 8, Linux, and Mac OS X Lion and Mavericks (Most testing procedures and debugging were performed on these platforms).</td>
</tr>
<tr>
<td>UI Application</td>
<td>MagicDraw® 18.0 or greater</td>
<td></td>
</tr>
<tr>
<td>Java Virtual Machine (JVM)</td>
<td>JDK 1.8.0</td>
<td>JDK 1.8.0_25 for Windows</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JDK 1.8.0_25 for Mac OSX</td>
</tr>
</tbody>
</table>

## 1.3 Licensing

You need to acquire a valid DataHub license key to be able to use DataHub features. You can either download an evaluation key or purchase a commercial one. The evaluation key allows you to use DataHub with all of its features but for a limited time only.

## 1.4 Changelog

The following are the changes in this version of Cameo DataHub:

- DataHub Relation has been renamed to DHLink.
- Server component of Cameo DataHub is no longer present separately. Previously the relation map was stored on the DataHub Server leading to conflicts in multi-user environments. Now the DHLink map is stored along with the project thus resolving conflicts involving multiple users working on the same data sets.
- Cameo DataHub no longer supports IBM® Rational® Requisite Pro or Cameo Requirements+ or MagicRQ. It only supports IBM® Rational® DOORS®, IBM® Rational® DOORS® Next Generation, and CSV data sources.
- Scope sync, auto sync and manual sync are no longer present separately. They have been combined into a single Synchronization mode, which can be either unidirectional or bidirectional, and works exactly like scope sync relation.
- OSLC link support for IBM® Rational® DOORS® Next Generation has been added.
- OSLC Query support for IBM® Rational® DOORS® Next Generation has also been added.
To resolve conflicts between un-synchronized data, a new **Conflict Dashboard** has been added to resolve conflicts and monitor status of data nodes. The **Conflict Dashboard** allows you to fine tune the way synchronization takes place within projects.

- Text search from DataHub Explorer and Alias Explorer has been added.
- Cameo DataHub inactive data source filtering has been added.
- Data copy progress bar has been enhanced with better status messages.
- The copy dialog has been improved, and it allows for a variety of mapping between source and target types.
- Migration support for DataHub 17.0.2 onwards is possible.

## 1.5 Installation

The recommended way to install the Cameo DataHub plug-in is by using the Resource/plug-in Manager.

To install the DataHub using Resource/plug-in Manager:

1. From MagicDraw® main menu, click **Help > Resource/Plugin Manager**. The **Resource/Plugin Manager** dialog will open Figure 1.
2. Select the **Cameo DataHub** check box under the **Plugins (Commercial)** option.
3. Click the **Download/Install** button.
4. Restart **MagicDraw®** once download/install process completes.
Cameo DataHub can also be installed from the source zip file if you have downloaded it to your local file system.

To install the DataHub from the source zip file do the following:

1. From MagicDraw® main menu, click Help > Resource/Plugin Manager. The Resource/Plugin Manager dialog will open, Figure 1.
2. Click the Import button to browse the local file system and locate the file.
3. Click the Close button of Resource/Plugin Manager dialog to close it.
1.5.1 Uninstallation

To remove the DataHub plug-in do the following

1. From MagicDraw® main menu, click Help > Resource Manager/Plugin. The Resource/Plugin Manager dialog will open.
2. On the Resource Manager/Plugin dialog, select Cameo DataHub from Plugins(commercial).
3. Click the remove button.

1.6 Upgrading from previous versions of DataHub

Upgrading DataHub version involves removing the older version first. After the current DataHub has been removed, you can use one of the two installation methods detailed in (1.5) Installation to re-install DataHub.

To upgrade DataHub version

1. Click Help > Resource/Plugin Manager.
2. Select Cameo DataHub from Plugins(commercial) and click the Remove button.
3. After you have removed the Cameo DataHub plugin, you can re-install it using one of the two installation methods mentioned in (1.5) Installation.

1.7 Migrating DataHub data from previous versions of DataHub

Starting from DataHub version 17.0.2 or later, DataHub data can be migrated using the Migrate DataHub menu item.

The current release of DataHub does not support data migration for Requisite Pro, Cameo Requirements+, and MagicRQ plugin data sources. The current release only supports data migration from DOORS and CSV data sources to MagicDraw® and vice versa, or from MagicDraw® to DOORS and CSV data sources. Either the source or target must be a MagicDraw® data source.

To migrate DataHub data do the following

1. Open a MagicDraw® project. This can be a local or TeamWork project.
2. Start DataHub explorer. Then, add all the data sources you would like to migrate and connect them.
3. Click Tools > DataHub > Migrate DataHub from MagicDraw® main menu. The migration dialog, Figure 2, will appear.
4. Choose either the first or second option. If you chose the first option, select the DataHub version to migrate from the list. If you chose the second option, click the Browse button to locate the DataHub directory. In Windows, this is C:\Users\userdirectory\datahub, and under Linux, it is /home/userdirectory/datahub.
5. Click the Migrate button on the migration dialog.
6. The DHLink from the older version of DataHub will be migrated to the current DataHub version.
1.8 Running DataHub

Once the DataHub plug-in has been installed and the license added, it will be ready to use.

To start the DataHub plug-in:

1. Start MagicDraw® and open an existing or new project.
2. Click Tools > DataHub > DataHub Explorer to open the DataHub explorer.

The next chapter deals with all aspects of the DataHub User Interface elements and subsequent chapters explains how to use those features to accomplish various DataHub tasks.
This chapter is an introduction to the various elements of the DataHub User Interface, menus, dialogs, context menus, tabs and panels.

Cameo DataHub lets you work with requirement management tools such as IBM® Rational® DOORS® and IBM® Rational® DOORS® Next Generation, and MagicDraw®. The DataHub lets you copy and synchronize requirements. DHLink links requirements to one another and also links requirements to system design models and test cases.

DataHub provides synchronization capabilities between target and source nodes which can be unidirectional or bidirectional. A synchronization conflict dashboard shows the sync status and options for additional synchronization.

Before you can use DataHub to connect with IBM® Rational® DOORS®, Driver Deployment(from DataHub menu) must be done.

## 2.1 DataHub Menu

To access the DataHub menu, you need to start MagicDraw® and then open a new or existing project.

To open the DataHub menu in MagicDraw®:

1. Click **Tools > DataHub**, Figure 3. The DataHub menu items will open.
Table 2 below explains the functions of the DataHub menu items.
Table 2 -- DataHub’s Menu Items in MagicDraw®

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronize</td>
<td>Synchronizes the node if there are any pending changes, does nothing otherwise.</td>
</tr>
<tr>
<td>DataHub Explorer</td>
<td>Opens the DataHub Explorer tab.</td>
</tr>
<tr>
<td>DHLink Panel</td>
<td>Opens the DHLink Panel</td>
</tr>
<tr>
<td>Prepare Data for Module</td>
<td>Opens the prepare data for module dialog</td>
</tr>
<tr>
<td>Clean Up DataHub Database</td>
<td>Opens the clean up database dialog</td>
</tr>
<tr>
<td>DHLink Summary</td>
<td>Opens the DHLink Summary dialog</td>
</tr>
<tr>
<td>Schema Map Manager</td>
<td>Opens the Schema Map Manager dialog</td>
</tr>
<tr>
<td>Alias Manager</td>
<td>Opens the Alias Manager dialog</td>
</tr>
<tr>
<td>Create OSLC Query</td>
<td>Opens the OSLC Query Editor dialog</td>
</tr>
<tr>
<td>Migrate DataHub</td>
<td>Opens the DataHub data migration tool. DataHub data from older versions of DataHub can be migrated to the latest version of DataHub.</td>
</tr>
<tr>
<td>Driver Deployment</td>
<td>Opens the Driver Deployment dialog</td>
</tr>
<tr>
<td>Actions</td>
<td>Opens the Actions menu</td>
</tr>
<tr>
<td>3rd Party Libraries Info</td>
<td>Opens the 3rd Party Libraries Info dialog</td>
</tr>
</tbody>
</table>

NOTE: Some of the items of the DataHub menu may be disabled if those items are not applicable in the current context. For example, the Create OSLC query menu item will only be enabled if you have a IBM® Rational® DOORS® Next Generation data source open.
The Actions menu item, Figure 4 contains more menu items. Table 3 below explains the DataHub Actions menu items.
### Table 3 -- DataHub Actions’ Menu Items

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Data Source</td>
<td>This option opens the Add Data Source dialog.</td>
</tr>
<tr>
<td>Connect</td>
<td>This option, if enabled, connects to the selected data source.</td>
</tr>
<tr>
<td>Close Data Source</td>
<td>Closes a data source.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves changes to the data source.</td>
</tr>
<tr>
<td>Remove Data Source</td>
<td>Removes the data source from the DataHub explorer instance.</td>
</tr>
<tr>
<td>New Node</td>
<td>Adds a new node under the selected node or data source.</td>
</tr>
<tr>
<td>Delete Node</td>
<td>Removes the selected node.</td>
</tr>
<tr>
<td>Reload</td>
<td>Reload all properties and items on the selected item and sub-item.</td>
</tr>
<tr>
<td>Select in Application</td>
<td>Selects the selected node in the original application.</td>
</tr>
<tr>
<td>Go to the Other Related Link</td>
<td>Go to a related linked item (within the DataHub Explorer)</td>
</tr>
<tr>
<td>Check Node Changes</td>
<td>Review all nodes that have been changed or edited without synchronizing them. The Check Node Changes menu contains two submenus:</td>
</tr>
<tr>
<td></td>
<td>• Check Nodes Changes: see changes only in a selected node, or</td>
</tr>
<tr>
<td></td>
<td>• Check Nodes Changes Recursively: see changes in both selected node as well as its children.</td>
</tr>
<tr>
<td>Synchronize</td>
<td>Send data updates from a selected data source to all of the related items in the other tools. The Synchronize menu contains two submenus:</td>
</tr>
<tr>
<td></td>
<td>• Synchronize Node: synchronize data only in a selected node.</td>
</tr>
<tr>
<td></td>
<td>• Synchronize Node Recursively: synchronize data under selected node and all its child nodes.</td>
</tr>
<tr>
<td>Update DHLink</td>
<td>Updates pending update and pending delete DHLink.</td>
</tr>
<tr>
<td>Remove DHLink</td>
<td>Removes all the DHLink information from selected node.</td>
</tr>
<tr>
<td>Create Alias</td>
<td>Creates an alias for the selected node and adds it to the alias manager.</td>
</tr>
<tr>
<td>Properties</td>
<td>Opens the properties panel for a selected node.</td>
</tr>
</tbody>
</table>

**NOTE** Removing a data source will delete all of its mappings and DHLink.

### 2.1.1 Hot Keys

The DataHub hot keys are available in MagicDraw®. You can define a set of hot keys to execute particular DataHub commands that are available on the list.

The following DataHub functions can be assigned hot keys:

- Add Data Source
- Check Node Changes Recursively
- Check Node Changes
- Clean up DataHub Database
To assign a hot key to any of the above DataHub functions

1. Click **Options > Environment > Keyboard**, from MagicDraw® main menu and select **Tools** from the **Category** drop-down list box.
2. Select the function from the list on the left.
3. Type the key or key combination you would like in the press new shortcut key text box on the right.
4. Click the **Assign** button

**Note**
If the key or key combination has already been assigned to another function it will display in the space below. In that case, choose another key combination.

### 2.2 DataHub Explorer Tab

The DataHub explorer tab has toolbar options for the following actions:
- Add a new data source
- Close a data source
- Open a data source
- Filter inactive data source
- Create OSLC Query
- Work with data in the tree
- Search for items
You can use **DataHub Explorer** toolbar buttons and context menu items to connect, add, or remove data sources. You can also use it to view drivers, data sources, and items of the connected data sources in the DataHub tree. You can also apply a filter to display only the connected data sources in the DataHub Explorer.

To open the DataHub Explorer do the following:

1. Start MagicDraw® and open an existing project or start a new one.
2. Then click **Tools > DataHub > DataHub Explorer** from MagicDraw® main menu.
3. The DataHub Explorer tab will open, Figure 5.

The **DataHub Explorer** tab (Figure 5) contains the following:

- Operation drop-down list
- Tree of data sources
- Explorer buttons and icons
- Text search text box

### 2.2.1 DataHub Operations drop-down

The DataHub operations drop-down provides a means for selecting which operation mode the DataHub is going to run in. The three operation modes available are as follows, Figure 6.

(i) **Copy Data**

(ii) **Copy Data With Sync**

(iii) **Create OSLC Link**
2.2.1.1 Copy Data

This option only copies data. It does not allow for synchronization.

2.2.1.2 Copy Data with Sync

This DataHub operation mode allows for copying data with synchronization. Synchronization between source and target nodes, either unidirectional or bidirectional can be accomplished in this mode.

2.2.1.3 Create OSLC Link

Typically an OSLC link is a relation between two life cycle artifacts. Relationships are modeled with two links: a forward link and a back link. They can be of the following types.

Table 4 -- OSLC Link Types

<table>
<thead>
<tr>
<th>Relation</th>
<th>Link Property</th>
<th>Backlink Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>implementation</td>
<td>oslc.implementedBy</td>
<td></td>
</tr>
<tr>
<td>constrain</td>
<td>oslc.constrains</td>
<td>oslc.constrainedBy</td>
</tr>
<tr>
<td>elaborate</td>
<td>oslc.elaborates</td>
<td>oslc.elaboratedBy</td>
</tr>
<tr>
<td>satisfy</td>
<td>oslc.satisfies</td>
<td>oslc.satisfiedBy</td>
</tr>
<tr>
<td>affect</td>
<td></td>
<td>oslc.affectedBy</td>
</tr>
<tr>
<td>specify</td>
<td>oslc.specifies</td>
<td>oslc.specifiedBy</td>
</tr>
<tr>
<td>track</td>
<td></td>
<td>oslc.trackedBy</td>
</tr>
<tr>
<td>decompose</td>
<td>oslc.decomposes</td>
<td>oslc.decomposedBy</td>
</tr>
<tr>
<td>validate</td>
<td></td>
<td>oslc.validatedBy</td>
</tr>
</tbody>
</table>

2.2.2 DataHub Tree

DataHub tree is composed of nodes each of which represents either a node or a connected data source. Data in the DataHub tree is arranged hierarchically in a tree structure. It represents all the data that DataHub is holding at that time.

2.2.3 DataHub Explorer Buttons and Icons

Table 5 below lists the icons of the DataHub Explorer tab.
## Table 5 – DataHub Browser Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="DH" /></td>
<td>DataHub</td>
<td>The DataHub root.</td>
</tr>
<tr>
<td><img src="image" alt="MagicDraw® Driver" /></td>
<td>MagicDraw® Driver</td>
<td>The MagicDraw® driver to connect to a MagicDraw® project.</td>
</tr>
<tr>
<td><img src="image" alt="Drivers" /></td>
<td>Drivers</td>
<td>The drivers to connect to the other tools (CSV, IBM® Rational® DOORS®, and IBM® Rational® DOORS® Next Generation).</td>
</tr>
<tr>
<td><img src="image" alt="Disable" /></td>
<td>Toggle showing only connected data sources</td>
<td>Clicking this button will hide all disconnected data sources from the DataHub explorer tab.</td>
</tr>
<tr>
<td><img src="image" alt="Enable" /></td>
<td>Toggle showing all data sources</td>
<td>Clicking this button will display all data sources from the DataHub explorer tab.</td>
</tr>
<tr>
<td><img src="image" alt="Add Data Source button" /></td>
<td>Add Data Source button</td>
<td>Click this button to start the Add Data Source dialog.</td>
</tr>
<tr>
<td><img src="image" alt="Synchronize button" /></td>
<td>Synchronize button</td>
<td>Click this button to start the synchronization process.</td>
</tr>
<tr>
<td><img src="image" alt="Disconnected Data Source" /></td>
<td>Disconnected Data Source</td>
<td>The repository of a MagicDraw®, IBM® Rational® DOORS®, or a CSV file. The data source is disconnected from its source.</td>
</tr>
<tr>
<td><img src="image" alt="Folder, Package" /></td>
<td>Folder, Package</td>
<td>A folder or a package.</td>
</tr>
<tr>
<td><img src="image" alt="DOORS Link" /></td>
<td>DOORS Link</td>
<td>A link in the IBM® Rational® DOORS® application.</td>
</tr>
<tr>
<td><img src="image" alt="Item" /></td>
<td>Item</td>
<td>Any item, for example, an IBM® Rational® DOORS® object, MagicDraw® element, or a CSV item.</td>
</tr>
<tr>
<td><img src="image" alt="Create OSLC Query button" /></td>
<td>Create OSLC Query button</td>
<td>Clicking this button opens the OSLC Query Editor dialog which lets you perform basic and advanced queries to an IBM® Rational® DOORS® Next Generation data source. This becomes enabled once you add an IBM® Rational® DOORS® Next Generation data source.</td>
</tr>
<tr>
<td><img src="image" alt="DataHub explorer Trash Icon" /></td>
<td>DataHub explorer Trash Icon</td>
<td>Drag and drop items you want to delete onto the trash icon. A confirmation dialog will appear before the item is actually deleted.</td>
</tr>
</tbody>
</table>
2.3 DataHub Properties Tab

The DataHub Properties tab shows the properties and associations of a selected node in the DataHub Explorer. You can update, delete, or open the following items in the DataHub Properties tab:

- MagicDraw® elements
- DOORS objects and modules
- CSV items
- IBM® Rational® DOORS® Next Generation Artifacts

The DataHub Properties tab shows all property names and values of an item selected in DataHub Explorer.

To open the DataHub Properties tab in MagicDraw®:

1. Right-click a node in DataHub Explorer and click Properties. The DataHub Properties will open in MagicDraw®, Figure 7.
2. Alternatively you can double-click the node in DataHub Explorer to open the properties tab. The selected item’s properties will be displayed.

You can edit and save a property value in the DataHub Properties tab. Read-only and multivalued properties are not modifiable. However, you can edit a multivalued property through its Specifications dialog.

Table 6 below explains the function of each icon in the DataHub Properties tab in MagicDraw®.

NOTE: The DHLink Panel will open whenever the DataHub Properties tab is open.
Table 6 -- DataHub Properties Icons and Their Functions in MagicDraw®

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Categorized View</td>
<td>To show all property names by category.</td>
</tr>
<tr>
<td></td>
<td>Alphabetical View</td>
<td>To show all property names in an alphabetical order.</td>
</tr>
<tr>
<td></td>
<td>Show Description</td>
<td>To show a description of each property.</td>
</tr>
<tr>
<td></td>
<td>Expand</td>
<td>To show all property names and values.</td>
</tr>
<tr>
<td></td>
<td>Collapse</td>
<td>To hide all property names and values.</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>To save changes made to a property name or value. The button will be enabled when the value of a property changes.</td>
</tr>
</tbody>
</table>

2.4 DHLink Panel

Information about links between elements are arranged in a tabular form in the DHLink panel. This tab shows the details of all the links you have added to items from the DataHub operation box.

DataHub Link or DHLink maintains synchronization between source and target elements, either bidirectional or unidirectional.

To open the DHLink Panel in MagicDraw®:

1. Click Tools > DataHub > DHLink Panel
2. The DHLink Panel will open, Figure 8.

The DHLink Panel contains several icons and a table. Each node in the table has a context menu called Actions menu that helps you manage the node and its relations.
Table 7 below gives the description of each column of the table in the DHLink Panel.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source by Source Driver name</td>
<td>The source data source type and name</td>
</tr>
<tr>
<td>Direction</td>
<td>The direction of DHLink synchronization.</td>
</tr>
<tr>
<td>Target by Target Driver name</td>
<td>The target data source type and name.</td>
</tr>
<tr>
<td>Status</td>
<td>The DHLink status that shows the status of the node, whether it is modified, moved, deleted or synchronized.</td>
</tr>
<tr>
<td>Property button column</td>
<td>This column contains the Property button. Clicking it opens up the node's properties panel.</td>
</tr>
</tbody>
</table>

NOTE: You can click the Property button to open details of the Target node.

2.4.1 Context Menu

You can right-click an item in the table in the DHLink Panel to open a context menu, Figure 9. This context menu allows you to execute specific operations on a node in the DHLink Panel.

Figure 9 -- DataHub DHLink Panel context menu

Table 8 below explains the functions of the DHLink Panel Context menu.
When there are pending update or pending delete items, there are some additional items on the context menu from DHLink Panel, Figure 10.

Table 8 -- DHLink Panel Context Menu items and their Functions

<table>
<thead>
<tr>
<th>Context Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Schema Map</td>
<td>Opens the schema map manager</td>
</tr>
<tr>
<td>Change Direction</td>
<td>Changes the direction of synchronization. This option has three sub-options - Two-way Sync, Source to Target only, and Target to Source only</td>
</tr>
<tr>
<td>Exclude Node</td>
<td>Excludes the node from being included for synchronization.</td>
</tr>
<tr>
<td>Remove DHLink</td>
<td>Removes the DHLink reference</td>
</tr>
<tr>
<td>Select in Application</td>
<td>This selects the DH linked Node in the Application, if it is DOORS, the DOORS client will activate, with that node selected.</td>
</tr>
</tbody>
</table>

Table 9 below describes the function of each of these menu items.

Table 9 -- DHLink Panel context menu for pending update and pending delete data nodes

<table>
<thead>
<tr>
<th>Context Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Schema Map</td>
<td>Opens the Schema Map Manager dialog.</td>
</tr>
<tr>
<td>Update Pending DHLink</td>
<td>Synchronizes the node by updating the pending DHLink.</td>
</tr>
<tr>
<td>Discard Update</td>
<td>Synchronizes the node by discarding the DHLink.</td>
</tr>
<tr>
<td>Exclude Node</td>
<td>Excludes the node from being included for synchronization.</td>
</tr>
<tr>
<td>Remove DHLink</td>
<td>Removes the DHLink reference</td>
</tr>
</tbody>
</table>
Select in Application: This selects the DH linked Node in the Application, if it is DOORS, the DOORS client will activate, with that node selected.

NOTE:
- DataHub cannot recreate a node if its parent does not exist.
- You can perform the Change Direction and Remove DHLink command (sync relation) on a root node only.

Figure 11 -- Sync Status Icons

Figure 11 shows the sync status icons on the DHLink Panel.

You can click the Sync Status button to filter the status of synchronization. The DHLink Panel will display only DHLink with the Sync status you have selected. You can find all of the Sync status icons in Table 10 below.

Table 10 -- Colors and Meanings of Sync Status Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Color</th>
<th>Sync Status</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Green</td>
<td>Synchronized</td>
<td>To display only the DHLink of the Synchr-</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>onized status.</td>
</tr>
<tr>
<td></td>
<td>Blue</td>
<td>Orphan</td>
<td>To display only the DHLink of the Orphan</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>status.</td>
</tr>
<tr>
<td></td>
<td>Red</td>
<td>PendingDelete</td>
<td>To display only the DHLink of the Pending-</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Delete status.</td>
</tr>
<tr>
<td></td>
<td>Yellow</td>
<td>PendingUpdate</td>
<td>To display only the DHLink of the Pending-</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Update status.</td>
</tr>
<tr>
<td></td>
<td>Grey</td>
<td>Excluded</td>
<td>To display only the DHLink of the Exclud-</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ed status.</td>
</tr>
</tbody>
</table>

2.5 DataHub Alias

An alias can be created from any node or data source. The DataHub Alias Manager stores all available aliases and they can be either accessed or removed from there.
2.5.1 Alias Manager

The DataHub Alias Manager contains a list of all available aliases. It stores these aliases for later use and you can either access or remove them.

To open the Alias Manager:

1. Click **Tools > DataHub > Alias Manager**, Figure 12

![Figure 12 -- DataHub Alias Manager](image)

2.6 Data Sources

A data source is typically a reference to some data. Data in a DOORS repository can be setup as a data source from within DataHub. A data source can be any of the following:

- A MagicDraw® project
- An IBM® Rational® DOORS® Next Generation
- An IBM® Rational® DOORS® Client
- A CSV file repository

A data source connects to a driver of the same application, for example, a DOORS driver must be first be added to add a DOORS data source. The DataHub driver will start automatically whenever you run Magic-Draw® or IBM® Rational® DOORS®.

2.7 Schema Map and Mapping Options

DataHub provides two mapping modes to simplify the way you map source and target nodes: (i) **Group type mapping** and (ii) **Individual type mapping**. These schema mapping methods are accessible through the *Copy Data* dialog. Additional options such as excluding unmapped nodes is also available.
There is also a Define Target Type from Attribute Value mapping mode. This is only available in Group Type Mapping mode. Once you use the Define Target Type from Attribute Value mapping mode, DataHub will save it as a default mode and activate it the next time you copy the same type of data. In such cases, the Copy Dialog will not open.

### 2.7.1 Individual Type Mapping

The individual type mapping feature in DataHub arranges all nodes into a tree structure. You can select a node from the source node and map it to a type in the target node. The auto-mapping feature of DataHub allows you to map similar node types automatically. However, you still can change the target type that has been mapped using the auto-mapping functionality.

### 2.7.2 Group Type Mapping

The default mapping type in DataHub is group type mapping. If you prefer mapping node types to mapping the nodes one by one before copying and/or synchronizing them, then you can select the Group Type Mapping mode. It arranges all nodes according to their types so you will see the types instead of the nodes arranged in a tree structure. You can select a type from the source tree and map it to another type in the target tree. Each formal module in DOORS will be categorized as one node type.

### 2.7.3 Define Target Type from Attribute Value Mapping

The Define Target Type from Attribute Value mapping mode is the capability to specify or define which type of node to map in the target by using a node’s attribute value in the source as the condition. This mode is available in the Copy Data dialog for the Group Type mapping option. The Define Target Type from Attribute Value mapping mode gives greater possibilities to select the attribute’s values of a node and map them to multiple target types.

### 2.7.4 Schema Map Manager

You can use Schema Map Manager to edit attributes mapping. Once the DHLInk between nodes and attributes have been created, Schema Map Manager will save the mapped nodes and attributes. You can edit the attribute map for a specific schema map. You can also export the mappings to XML format and share them with other parties.

### 2.7.5 Schema Map Templates

DataHub provides schema map templates in each application (MagicDraw® and DOORS) by default. The templates are available in the Cameo DataHub Schema Map Manager dialog. They allow you to select a type of node to map in the target application and edit the attributes. You can also select a target type as a default one so that the next time you map similar data attribute from any source, they will always be saved in the same target type.

### 2.8 Driver Deployment

DataHub supports driver deployment for DOORS client. This enables the DOORS application to activate its DataHub menu item and also allows DataHub to create DOORS data sources.

To deploy the DOORS driver in DataHub

1. Click **Tools > Datahub > Driver Deployment** from MagicDraw® main menu.
2. The driver deployment dialog appears, Figure 13.
3. Select the DOORS version you would like to add and then click the Add button.
4. A browse dialog will open and you will have to navigate to the DOORS installation directory. Once that is done the driver will be loaded.

2.9 Prepare Data For Module

This DataHub feature allows you to split a part of a project into an independent project or module. Prepare Data For Module will extract the DHLink information associated with the module’s items and package it along with the module’s items so you can perform synchronization on the module independently of the main project. In order to use this DataHub feature, you need to save the project before you prepare data for module and after it is done, you will need to save, close and re-open your project again. This is to prevent DHLink references being lost. The Prepare Data For Module dialog is shown below and can be accessed from Tools > DataHub > Prepare Data For Module

2.10 NEW! OSLC Support

Starting from Cameo DataHub 18.1, DataHub began implementing features to support OSLC interactions. Open Services for Lifecycle Collaboration (OSLC) is a community that is standardizing the way that life cycle tools work together. With support for OSLC, DataHub can easily communicate with other software such as
IBM® Rational® DOORS® Next Generation and IBM® Rational® DOORS®, which also supports OSLC integration. This means you can share and use linked data, analyze, track, and explore them via OSLC links between DOORS Next Generation artifacts and DataHub data nodes.

DataHub supports the following:
- OSLC Link support for IBM® Rational® DOORS® Next Generation
- OSLC Query support for IBM® Rational® DOORS® Next Generation

2.11 NEW! Add-on Features

The current release of DataHub features enhanced capabilities and emphasizes accessibility and user-friendliness. The conflict dashboard displays synchronization options in a tabular form and enables you to choose the item and the direction of synchronization.

2.11.1 Conflict Dashboard

When you Copy Data with Sync from DOORS, DOORS Next Generation, or CSV data sources, the DataHub keeps track of the changes of both source and target nodes. When a node is changed, moved, or deleted, on any side, you can perform data synchronization using the Conflict Dashboard, Figure 15.

To access the conflict dashboard:
1. Copy data nodes with sync, then edit, move, or delete some of these nodes.
2. Next, from DataHub explorer right-click the node and select item Check Node Changes or Check Node Changes Recursively.
2.11.2 Components of Conflict Dashboard

The Conflict Dashboard is comprised of the following components:

- **Source** and **Target** data trees
- **Display** drop-down
- **Properties** panel
- Node colors
- **Synchronize** and **Close** buttons

The Display and Properties drop-down lists are explained below.

**2.11.2.1 Display drop-down**

The display drop-down allows you to filter the pending synchronizations according to their type, Figure 16.
2.11.2.2 Properties Panel

The Conflict Dashboard Properties panel shows the properties and attributes of the source and target nodes.

2.11.2.3 Node Changes

The Conflict Dashboard displays node changes in a simple color coded scheme as in Table 11.
Table 11 -- Color and their meaning in Conflict Dashboard

<table>
<thead>
<tr>
<th>New Entity</th>
<th>Color</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Entity</td>
<td>Green</td>
<td>Refers to a new node in the scope, or a deleted node at the end of a one-way sync (re-create).</td>
</tr>
<tr>
<td>Modified</td>
<td>Blue</td>
<td>Refers to a modified node</td>
</tr>
<tr>
<td>Moved</td>
<td>Yellow</td>
<td>Refers to a moved node</td>
</tr>
<tr>
<td>Deleted</td>
<td>Pink</td>
<td>Refers to a deleted node, or a new node at the end of a one-way sync (force-delete)</td>
</tr>
<tr>
<td>Out of Scope</td>
<td>Red Lettering</td>
<td>Refers to a node that is no longer within the scope of the root node.</td>
</tr>
<tr>
<td>Excluded</td>
<td>Gray Lettering</td>
<td>Refers to a node that has been excluded from synchronization.</td>
</tr>
</tbody>
</table>

Note: The Conflict Dashboard can be opened by clicking Check Node Changes or Check Node Changes Recursively from any data source except MagicDraw® data source.

2.11.3 Text Search in DataHub Explorer and Alias Manager

The text search capability in DataHub Explorer allows you to search for data or item in DataHub, Figure 18.

![DataHub Explorer Text Search box](image)

Figure 18 -- DataHub Explorer Text Search box

2.11.4 Inactive Data Source Filter

Inactive Data Source Filter is available as a button on the DataHub explorer toolbar. You can use this filter to filter out all inactive data sources from the DataHub Explorer tree, Figure 19.
2.11.5 Data Copy Progress Bar

When copying data, DataHub shows the progress through its progress bar, Figure 20.
3 WORKING WITH DATAHUB IN MAGICDRAW

Customizing DataHub Options

DataHub is a fully functional plug-in for MagicDraw®, IBM® Rational® DOORS®, IBM® Rational® DOORS® Next Generation, and CSV files.

It lets you work with the above mentioned requirement management tools, providing three main functions.

- Copy
- Link
- Synchronize

You can copy requirement objects, link them to one another as well as system models such as Use Case and SysML diagrams, create OSLC links, and finally synchronize the repositories. OSLC support and how to use it with Cameo DataHub is also explained in this chapter.

In order to use Cameo DataHub, make sure you have deployed it in your application. The DataHub plug-in works with both Local and Teamwork projects. However, only the Locked For Edit Teamwork project elements can perform DataHub functions such as copying, creating OSLC link or query, or synchronizing data.

NOTE: To load a MagicDraw® Teamwork project as a data source in DataHub, you need to first log into MagicDraw® Teamwork Server.

3.1 Customizing DataHub Options

The Cameo DataHub Options dialog allows you to enable popup dialogs for some particular actions in DataHub.

To open the Options dialog in MagicDraw®:

1. Click Options > Environment. Then select Cameo DataHub from the list on the left, Figure 20.
Figure 20 -- Options Dialog in MagicDraw

The Options dialog in MagicDraw® is divided into the following two groups of configuration:

3.1.1 General

3.1.2 Confirmation
3.1.1 General

DataHub allows you to select default options for mapping type, filter, or synchronization through the General option.

To modify the DataHub General option:

1. Click Options > Environment from MagicDraw’s main menu. The Cameo DataHub Options dialog will open, Figure 21.
2. Click the General category on the left-hand side.
3. Edit the settings if necessary.
4. Click OK.

Table 11 below explains the general preferences in the Cameo DataHub Options dialog.
### 3.1.2 Confirmation

You can also adjust the behavior of the **Confirmation** popup dialogs in DataHub through the **Confirmation** option tab.

To enable or disable the confirmation dialogs in MagicDraw®:

1. Click **Options > Environment > Cameo DataHub** on the main menu.
2. The **Cameo DataHub Options** dialog will open, Figure 22.
3. Click the + icon beside **Confirmation**.
4. Select or de-select the pop-up dialogs that you want to enable or disable.
5. Click **OK**.

---

**Table 11 -- DataHub General Option**

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronize data when saving project</td>
<td>To enable automatic synchronization with MagicDraw® whenever you save a project.</td>
</tr>
<tr>
<td>Set the Group Type Mapping as the default mapping</td>
<td>To set the default mapping to Group Type Mapping by selecting the check box when copying data.</td>
</tr>
<tr>
<td>Filter a MagicDraw data source from DataHub Explorer</td>
<td>If this check box is checked, MagicDraw® data sources will not be displayed in DataHub explorer, and vice-versa.</td>
</tr>
<tr>
<td>Mapping Policy</td>
<td>This drop-down box lets you select between different options to display the mapping dialog. They are as follows.</td>
</tr>
<tr>
<td></td>
<td>- Always show the mapping dialog</td>
</tr>
<tr>
<td></td>
<td>- Show mapping for elements without default mapping</td>
</tr>
<tr>
<td></td>
<td>- Show mapping for elements that cannot be automatically mapped</td>
</tr>
<tr>
<td></td>
<td>- Treat no-default mapping element as exclude</td>
</tr>
</tbody>
</table>
Table 12 below explains the confirmation options in the DataHub Options dialog.
### Table 12 -- DataHub Confirmation Option

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show a confirmation dialog when synchronizing data.</td>
<td>To open a confirmation dialog before synchronizing data.</td>
</tr>
<tr>
<td>Show a warning dialog about loss of Rich Text format when copying or synchronizing data.</td>
<td>To open a message warning you about copying or synchronizing data will erase the Rich Text format.</td>
</tr>
<tr>
<td>Show a confirmation dialog when deleting a node action.</td>
<td>To open a confirmation dialog before deleting a node.</td>
</tr>
<tr>
<td>Show a confirmation dialog when deleting a Pending Delete status.</td>
<td>To open a confirmation dialog before deleting a node whose status is PendingDelete.</td>
</tr>
<tr>
<td>Show a confirmation dialog when deleting a schema map.</td>
<td>To open a confirmation dialog before deleting a schema map.</td>
</tr>
<tr>
<td>Show a warning dialog when a schema being edited is used in another project.</td>
<td>To open a message when editing a schema that is used in another project.</td>
</tr>
<tr>
<td>Show a warning dialog when copying data.</td>
<td>To open a warning dialog before copying data when some nodes have not been completely mapped.</td>
</tr>
<tr>
<td>Show a warning dialog when saving a text property that causes formatting loss.</td>
<td>To open a message warning you about saving a property value will erase the format.</td>
</tr>
<tr>
<td>Show a warning dialog when synchronizing at another side of the Out of Scope node.</td>
<td>To open a message warning you about synchronizing data will relocate some out of the scope nodes on the other side within the DHLink.</td>
</tr>
<tr>
<td>Show a confirmation dialog when removing DHLink.</td>
<td>To open a confirmation dialog before removing the DHLink of a selected node.</td>
</tr>
<tr>
<td>Show a confirmation dialog when removing DHLinks recursively.</td>
<td>To open a confirmation dialog before removing DHLinks of the node and its hierarchy.</td>
</tr>
<tr>
<td>Show a confirmation dialog when replacing existing map.</td>
<td>To open a confirmation dialog before overwriting a schema map.</td>
</tr>
<tr>
<td>Show a confirmation dialog when updating all pending DHLinks recursively.</td>
<td>To open a confirmation dialog before updating all pending DHLinks of a node and its hierarchy.</td>
</tr>
<tr>
<td>Show a confirmation dialog when updating all pending DHLinks.</td>
<td>To open a confirmation dialog before updating all pending DHLinks of a selected node.</td>
</tr>
<tr>
<td>Show a confirmation dialog when updating Pending Update status.</td>
<td>To open a confirmation dialog before updating a node whose status is PendingUpdate.</td>
</tr>
</tbody>
</table>

**NOTE**
- An out-of-scope node is a node that has been relocated outside the root node. Therefore, the node hierarchy is changed.
- Synchronizing on the side where some out of scope nodes exist will not change the node hierarchy of the related nodes on the other side. Therefore, a warning message will not open. But synchronizing from the other side will move the out-of-scope nodes to their original location.
### 3.2 Working with the DataHub Explorer tree

While using the DataHub to work with requirements from a project in DOORS or CSV, it is required that first you create a data source. Data sources can be created for IBM® Rational® DOORS®, IBM® Rational® DOORS® Next Generation, or for CSV files.

Once you add the data source into MagicDraw® it will appear in the DataHub Explorer tree as a data source node.

#### 3.2.1 Working with Data Sources

Before connecting a data source to a driver, you need to have the DataHub Explorer tab open in MagicDraw®.

To open the DataHub Explorer:

1. Start MagicDraw® and create a new project or open an existing one.
2. Click **Tools > DataHub > DataHub Explorer** from MagicDraw® main menu.
3. The DataHub Explorer tab will open, Figure 23.

![DataHub Explorer](image)

**Figure 23 -- DataHub Explorer**

#### 3.2.1.1 Adding a CSV Data Source

To add a new CSV data source:

1. Click the **Add Data Source** button on the DataHub explorer toolbar, Figure 23. The **Add Data Source** dialog will open, Figure 24.
2. Select CSV from the driver drop-down. Figure 25.
3. Enter the CSV information in the following fields:

- **File**: the CSV file to be added.
- **Key**: the name of the column header that will be used as the ID of the node. If you leave it blank, a sequence number will be generated for the ID. The Key field is mandatory if **Copy Data with Sync** option is chosen.
- **Label**: the name of the column header that will be created as the name of the node. If you leave it blank, a running number will be assigned for the name.
- **Separator**: select a delimiter for the CSV file. The available delimiters are comma, semi-colon, space, and slash.
- **Save Option**: if you select the ** Automatically save after change** check box, DataHub will make changes to the CSV file once the CSV item is saved.
3.2.1.2 Adding an IBM® Rational® DOORS® Data Source

To add an IBM® Rational® DOORS® data source

1. Click the Add Data Source button on the DataHub Explorer tab. The Add Data Source dialog will open, Figure 26.

![Add Data Source](image)

Figure 26 -- Adding an IBM® Rational® DOORS® Data Source to DataHub explorer

2. Choose IBM® Rational® DOORS® driver from the driver drop-down, Figure 26.
3. Click the **Create** button and your DOORS data source should now appear in the DataHub explorer tab.

**Note**

To add an IBM® Rational® DOORS® data source, you must have started the DOORS client on your machine, otherwise MagicDraw® will generate an error dialog.

### 3.2.1.3 Adding an IBM® Rational® DOORS® Next Generation Data Source

To add an IBM® Rational® DOORS® Next Generation data source

1. Click the **Add Data Source** button on the DataHub explorer toolbar. The **Add Data Source** dialog will open, Figure 27.
2. Select IBM® Rational® DOORS® Next Generation from the driver drop-down, Figure 27.
3. Fill in the host, port, username and password fields. Click **Create** and a DOORS Next Generation data source should be visible in the DataHub explorer.

![Add Data Source](image)

*Figure 27 -- Adding an IBM® Rational® DOORS® Next Generation data source*

### 3.2.1.4 Display a MagicDraw® Data Source

MagicDraw® data sources are shown by default on the MagicDraw® containment tree and not the DataHub explorer tree. If, however, you wish to see MagicDraw® data sources in the DataHub explorer tree, then follow the steps below.
To display a MagicDraw® data source to DataHub explorer tree:

1. Click Options > Environment > Cameo DataHub.
2. In the General options group, de-select the Filter MagicDraw® data source from DataHub Explorer check box.
3. A MagicDraw® data source should now appear in the DataHub explorer tab, Figure 28.

![Figure 28 -- Display a MagicDraw data source](image)

**Note**

MagicDraw® elements can be used directly through the MagicDraw® containment tree. If, however, you wish to view a MagicDraw® data source in the DataHub explorer tree, then de-select the Filter MagicDraw® sources from DataHub options dialog. The default value of this option is true, so MagicDraw data sources are hidden by default, unless enabled through this option.

### 3.2.2 Closing and Opening Data Sources

To close an open data source

1. Right-click the data source on the DataHub explorer tree and choose the **Close Data Source** option.
2. Closing a data source doesn’t remove it from the DataHub explorer tree, it merely deactivates it.

To open or activate an inactive data source

1. Right-click the inactive data source and choose the **Connect** option.
2. The data source will be shown as connected.
3.2.3 Filtering Inactive Data Sources

To filter out inactive data sources

1. Click the Filter inactive data sources button from the DataHub explorer toolbar.

3.2.4 Removing a Data Source

To remove a data source

1. Right-click the data source you wish to remove and select the Remove Data Source option.
2. You will be prompted to confirm the remove action.
3. This option removes the data source from the DataHub explorer tree. It also removes all related DHLINK and Schema Map information from DataHub.

3.3 Adding a New Node to Data Source

You can use DataHub Explorer to add a new node in a particular application without switching to that application. In addition, the new node you have added in DataHub Explorer will also appear in the application itself. You can add a new node to any connected data source by using the New Node command in the DataHub action menu. The types of nodes available will vary, depending on the parent of the new node.

To add a new node to a specific data source:

1. Right-click a node and select New Node, Figure 29.

Figure 29 -- Adding a New Node to a MagicDraw Driver
2. Select a new node type and click **Next**, Figure 30.

![Figure 30 -- Available Node Types under Data Node](image)

**NOTE**

The types of new nodes will vary according to the drivers and parent nodes.

3. Type the new node’s properties details and click **Finish**, Figure 31.
3.4 Searching for a text string

To search for text:

1. Type the text you want to search into the search box, Figure 32.
2. The results of the search will be as shown in Figure 33, below.
3.5 Deleting Requirements

To delete a requirement from DataHub Explorer tree

1. Right-click the node you want to delete and select **Delete Node**.
2. Alternatively, you can drag and drop the node onto the DataHub explorer **Trash icon**.
3. A confirmation dialog asking you to confirm the delete will open.

3.6 Working with OSLC Query and OSLC Link

3.6.1 Creating OSLC Links

OSLC links and queries can be created once you have an IBM® Rational® DOORS® or IBM® Rational® DOORS Next Generation data source open in DataHub. See section 3.2.1.3 on how to create an IBM® Rational® DOORS® Next Generation Data Source

To create an OSLC Link do the following

1. Select **Create OSLC link** from the DataHub operations drop down on the DataHub explorer tab.
2. From the above IBM® Rational® DOORS® Next Generation data source, drag and drop a node into the MagicDraw® containment area.
3. A popup, Figure 34, will ask you what type of link. Choose one from the list and a link of that type will be created.
4. Figure 35 shows the newly created OSLC hyperlinks in the MagicDraw® containment tree. Figure 36 shows the OSLC hyperlink’s Properties and Figure 37 shows the OSLC hyperlink in the DHLink panel.
Figure 34 -- Figure OSLC Link types

Figure 35 -- OSLC hyperlinks in MagicDraw containment area
3.6.2 Create OSLC Query

There are two types of OSLC queries you can construct to query the DOORS Next Generation artifacts repository - simple or basic query and a more advanced query based on SQL or SPARQL, details of which can be found on the OSLC Specification website - http://open-services.net/.

To create and run a basic OSLC query, do the following.

1. Click **Tools > DataHub > Create OSLC Query** from MagicDraw® or click the **Create OSLC query** icon in DataHub explorer. The **OSLC query editor** window should appear. Figure 38.
2. The OSLC query editor has two tabs - **Basic Query** and **Query Editor**
3. Basic queries are simple text search queries. Type your search term into the basic query text box and click the **Run** button.
4. The results will appear, Figure 38.
5. After the query results appear you can click the **Save as alias** button to save the results in the Alias Manager.

To create and run an advanced query

1. Click the **Create OSLC Query** button on the DataHub explorer toolbar.
2. Click the **Query Editor** tab, see Figure 39 below. In the **Query String** textbox, type your query which might look like `https://10.1.1.70:9443/rm/views?oslc.query=true`, using simple query language or `https://host:port/bugs?oslc.select=dcterms:created,dcterms:creator{foaf:family-Name}&oslc.where=cm:severity="high"`, using SPARQL query language.
3. Click the Run button after you have entered your query string. The results of the query, if any, will appear in the lower part of the OSLC Query Editor. You can, optionally, click the Save as alias button to save the query result as an alias.

4. More examples of queries and their syntax can be found on the OSLC Specification website.

Figure 39 -- The OSLC advanced Query Editor tab
3.6.3 Copying OSLC Query Results

3.6.3.1 Copy OSLC Query Results to MagicDraw® as SysML Requirements

To copy OSLC query results into MagicDraw® as SysML requirements, first you need to set up a IBM® Rational® DOORS® Next Generation data source and then query the data source using OSLC query syntax. See section 3.2.1.3 Adding an IBM® Rational® DOORS® Next Generation Data Source. Once you have the query results you can copy them into MagicDraw® as SysML requirements.

To copy OSLC query results as SysML requirements

1. From OSLC Query result pane, drag and drop the matched tree onto the MagicDraw® containment tree, Figure 40.
2. When the **Copy** dialog opens up, choose **Extended Requirement** from the target type list as shown in Figure 42. Click **OK**.
3. The result of the copy is as shown in Figure 43.

---

**Figure 40 -- Copying OSLC Query result into MagicDraw**

**Figure 41 -- OSLC Query Editor Operations drop-down**

---

**Note** The OSLC Query Editor only supports **Copy Data** and **Create OSLC Link** as shown in Figure 41.
Figure 42 -- Copying OSLC query result as Extended Requirement
3.7 Creating Links between Elements

DataHub links are useful to create relationships between elements. The relationship determines how the elements react when one of the elements changes.

MagicDraw context menu also has a menu item to navigate to DHLinks.

To navigate to DHLinks from MagicDraw context menu:

1. Right-click a node in MagicDraw Containment Tree.
2. Select Go To > DHLinks as shown in Figure 44.

3.7.1 Creating DataHub Links

With DHLink, you can synchronize data between the source and target nodes. DataHub has two types of DHLink, unidirectional and bidirectional. (see Terminology in Appendix) You can create a DHLink by choosing Copy Data with Sync from the DataHub operation mode.

In addition to the above, OSLC links can also be created.
3.7.1.1 Copy Data with Sync

Copy data with Sync will update the source and target nodes automatically once you click Synchronize. In this case, use the following steps to update your data.

To create relations by using Copy data with Sync:

1. Select Copy data with Sync from the Operation drop-down, Figure 45.

   ![Figure 45 -- Copy Data with Sync operation](image)

2. Drag a source node to a target node, Figure 46. The Copy Data with Sync dialog opens to allow for choosing between Group mapping and Individual mapping modes, Figure 47, and also allowing you to map the attributes of source and target sides.
Figure 46 -- Dragging a source node to a target
Creating Links between Elements

Figure 47 -- Copy Data with Sync dialog in Group Type Mapping mode
3. When you finish mapping the attributes, click **OK**.

**NOTE**

Cameo DataHub comes with a pre-mapping template. If the data being copied is available in the mapping template, data will be copied right away without the **Copy Data with Sync** dialog, otherwise manual mapping is needed.
3.7.2 Removing Links

DataHub provides two options to remove the DHLink of a node.

(i) remove only DHLink of the selected node and

(ii) remove all DHLink in the node hierarchy.

To remove a relation, there are two options

1. Right-click either an item in the DataHub explorer and select Remove DHLink or Remove DHLink Recursively from the shortcut menu Figure 49 or
2. Select a DHLink in the DataHub DHLink panel, right-click and select Remove DHLink, Figure 50.
3.7.2.1 Navigate Selected Requirements in the DataHub Explorer/ Alias Explorer

To open selected requirement in DataHub Explorer/Alias Explorer

1. Right-click the requirement node you want to open and select **DataHub Actions > Select in DataHub Explorer/Alias Explorer**, Figure 51.
2. The requirement object will be selected in the DataHub explorer, or if the Alias manager is open, it will be selected there.

![Figure 51 -- Opening a selected requirement in DataHub Explorer/Alias Explorer](image)

3.7.2.2 Opening Selected Requirements in the Other Application’s Tree

To open selected requirements in an external application

1. Right-click the requirement node in DataHub explorer and select **DataHub Actions > Select in Application** menu item.
2. The external application will open with that requirement node selected as in Figure 52.
3.8 Copying Requirements

The DataHub operation mode in DataHub Explorer provides several options for you to work with your data. You can Copy Data, Copy Data with Sync, or Create OSLC Link, Figure 53.

Figure 53 -- DataHub Operation Mode
Table 13 below explains the functions of the DataHub operation mode in detail.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy Data</td>
<td>To copy data and child nodes only.</td>
</tr>
<tr>
<td>Copy Data with Sync</td>
<td>To copy data and create a DHLink between the original and new data to be copied. When DataHub synchronizes data using this mode, it will update or delete items whenever their associated items are changed or deleted. The DHLink will transfer the newly created nodes to the other associated tools as well.</td>
</tr>
<tr>
<td>Create OSLC Link</td>
<td>Create OSLC Link from IBM® Rational® DOORS® or IBM® Rational® DOORS® Next Generation to MagicDraw® element</td>
</tr>
</tbody>
</table>

You can copy data by dragging an item from the source to target. The source or target item can be any of the following:

- MagicDraw® element
- IBM® Rational® DOORS® formal module or object
- IBM® Rational® DOORS® Next Generation project area, folder or artifact
- CSV data

Dragging an item from the source to the target will copy the item and paste it on to the selected target item. Any relationship that exists within the copied items will automatically be copied to the target item.

**NOTE**
- The parent-and-child relationships will be transferred from the source to target items.
- The dependency relationships from MagicDraw® will also be transferred if both the source and target items are selected.

### 3.8.1 Copying Data

You can copy data from the MagicDraw's Containment tree to DataHub Explorer or vice versa, or you can copy data within DataHub Explorer by dragging the source item to the target item. In order to do this, you need to have a Data Type and a Schema Map. If no default data type or auto schema map is found in the system, Cameo DataHub will ask you to do the mapping.

DataHub provides two types of schema mapping modes: (i) **Individual Type Mapping** and (ii) **Group Type Mapping**. The default mapping mode will be displayed in the Copy Data dialog but you can change the default setting through the Options dialog. If you do not want to change your default mapping mode, you can switch to the other type in the Copy Data dialog.

If you mapped a schema with the Define target type from attribute value mapping mode previously, DataHub will save this mode automatically and use it as the default mapping mode. You still can change the default mapping mode through the Copy data dialog.

DataHub also provides a default schema map template for mapping data. You can find the default schema map template under the IBM® Rational® DOORS® driver in the Schema Map Manager dialog. If you select a schema map template for mapping once, the next time you want to copy the same type of data, DataHub will use the template again for mapping data types and attributes if the to be copied data matches the default schema map template. For example, if you copy an object from DOORS data source to MagicDraw®, DataHub...
will automatically choose a SysML requirement node as the target type the next time you copy data to the MagicDraw® driver. However, you can change the default schema map template when necessary.

Copying data allows you to share data from one application to another and optionally synchronize them at the same time. There are several ways to copy data and DataHub categorizes them into three operation types:

- Copy Data
- Copy Data with Sync
- Create OSLC Link

### 3.8.1.1 Copy Data

DataHub allows you to copy data without synchronization. Copying data works like copy and paste operation. If the node you want to copy does not have any default schema map, you have to resolve any unmapped nodes through the **Copy Data** dialog, Figure 55.

To copy data from a source node to target

1. Drag a source node to a target node and drop it, Figure 54.
2. The **Copy Data** dialog will open. Figure 55 shows the **Copy Data** dialog in **Group type mapping** mode while Figure 56 shows it in **Individual type mapping** mode.
3. Start mapping the source node attributes to target attribute types, you will see the node color change from a red circle to a green one, which means the node and its attributes have been mapped to a target type. The OK button will become enabled at this point and you can click it to finish the copy process.

![Figure 54 -- Copying data by dragging a source node to target](image)
Figure 55 -- The Copy Data Dialog in Group Type Mapping Mode
Copy Data
Select all unmapped target types from the list and resolve them by defining the schema map.

Figure 56 -- The Copy Data Dialog in Individual Type Mapping Mode
You can see the function of the **Copy Data** dialog in Table 14 below.

*Table 14 -- Components of the Copy Data Dialog*

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mapping Mode</strong></td>
<td>To switch between Individual Type Mapping and Group Type Mapping. The <strong>Mapping Mode</strong> drop-down menu always shows the default type that you selected through the <strong>Options</strong> dialog.</td>
</tr>
<tr>
<td><strong>Source Tree</strong></td>
<td>To specify a data tree of the source that will be copied. You will need to specify a target type for every source type. (See below for the status icon).</td>
</tr>
<tr>
<td>![Green Icon]</td>
<td>To identify a node whose source type has already been resolved.</td>
</tr>
<tr>
<td>![Red Icon]</td>
<td>To identify a node whose source type needs to be resolved before copying.</td>
</tr>
<tr>
<td>![Gray Icon]</td>
<td>To identify: *a node that will not be copied since the target type does not support any child. *a link that will not be copied since the source and/or the target type does not support links.</td>
</tr>
<tr>
<td><strong>Define Target Type from Attribute Value</strong> [Check Box]</td>
<td>To map by using the <strong>Define Target Type from Attribute Value</strong> mode. If you select this mode, you need to define the values and specify the target types of each value in the provided table. This mode is enabled in Group Type Mapping only.</td>
</tr>
<tr>
<td><strong>Attribute</strong></td>
<td>To select an attribute of a source node and define its values and a target type. The selected attribute is not available to be mapped for the Source Attribute in the schema map table.</td>
</tr>
<tr>
<td><strong>Define Value [Table]</strong></td>
<td>To define the values of a selected attribute and the target type of each value. The table consists of the following columns:</td>
</tr>
<tr>
<td><strong>Default</strong></td>
<td>You need to specify a default target type. If an attribute value does not match any mapped values when copying data or creating relations, then DataHub will use the default target type.</td>
</tr>
<tr>
<td><strong>Priority</strong></td>
<td>It is used when a defined attribute has multiple values. The first target type on the list has the highest priority and will always be selected first in the mapping process.</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>It allows you to select a value for a target type. If a selected attribute is an enumeration, you can choose the values from the drop-down list.</td>
</tr>
<tr>
<td><strong>Target</strong></td>
<td>It allows you to define a target type for a selected value.</td>
</tr>
<tr>
<td><strong>Quick search</strong></td>
<td>To find a particular type containing specific text in real time.</td>
</tr>
<tr>
<td><strong>Target Type tree</strong></td>
<td>To show all types that are allowed to be added according to the type you have selected in a Data Type tree.</td>
</tr>
</tbody>
</table>
3.8.1.2 Copy Data with Sync

When this operation mode is selected, a DHLink is added to the data which is used for synchronization. It maintains the structure and hierarchy of the elements within the node. During data synchronization, DataHub will search for any new nodes. If it finds some new nodes that are within the scope on one side, DataHub will copy them to the other side and create a synchronization relation between them.

The mapping process provides two options: (i) UNSPECIFIED and (ii) Exclude.

The UNSPECIFIED type option is available for Individual Mapping mode only. You can see the UNSPECIFIED type in the Target Type tree in the Copy Data with Sync dialog.

You can exclude nodes in the Copy Data with Sync dialog by checking the Exclude all unmapped nodes from DHLink check box. This option will mark the unmapped nodes with an exclude status and those nodes will not be copied. If you want to include unmapped nodes, navigate to DHLink panel and right-click and select Include Node from the context menu.

To Copy Data with Sync:

1. Drag and drop a source node onto a target node, Figure 57. The Copy Data with Sync dialog will open.
2. Figure 58 and Figure 59 shows the Copy Data with Sync dialog in Individual and Group mapping modes.
3. Click OK when the nodes and their attributes have been mapped to their respective target types.
Figure 57 -- Drag and drop a source node to target in Copy Data with Sync operation mode
Figure 58 -- The Copy Data with Sync Dialog in Individual Type Mapping Mode
Figure 59 -- Copy Data with Sync Dialog in Group Type Mapping Mode
### Table 15 -- Components of the Copy Data with Sync Dialog

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sync Direction</td>
<td>To select which to synchronize data from, either unidirectional or bidirectional:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Two-way Sync</strong>: allows you to synchronize data at either location (source node or target node).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Source to Target</strong>: to synchronize changes from a source node only.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Target to Source</strong>: to synchronize changes from a target node only.</td>
</tr>
<tr>
<td>Mapping Mode</td>
<td>To switch between Individual Type Mapping and Group Type Mapping. The <strong>Mapping Mode</strong> drop-down menu always shows the default type that you selected through the <strong>Options</strong> dialog.</td>
</tr>
<tr>
<td>Source Tree</td>
<td>To specify a data tree of the source that will be copied. You will need to specify a target type for every source type. (See below for the status icon).</td>
</tr>
<tr>
<td>![Green Icon]</td>
<td>To identify a node whose source type has already been resolved.</td>
</tr>
<tr>
<td>![Red Icon]</td>
<td>To identify a node whose source type needs to be resolved before copying. It refers to either a node that needs to be mapped or a node that needs to be excluded from the DHLink.</td>
</tr>
<tr>
<td>![Orange Icon]</td>
<td>To identify:</td>
</tr>
<tr>
<td></td>
<td>• a node that will not be copied since the target type does not support adding any child.</td>
</tr>
<tr>
<td></td>
<td>• a link that will not be copied since the source and/or the target type does not support creating links.</td>
</tr>
<tr>
<td>![Yellow Icon]</td>
<td>If a node is copied, and subsequently its parent is copied, then the copied node will have this icon to identify it as a node that has already been mapped and is now locked since it already has a DHLink sync relation.</td>
</tr>
<tr>
<td>Define Target Type from Attribute Value [Check Box]</td>
<td>To map by using the Define Target Type from Attribute Value mode. If you select this mode, you need to define the property values and specify the target types of each value in the provided table. This mode is enabled in Group Type Mapping only.</td>
</tr>
<tr>
<td>Attribute</td>
<td>To select an attribute of a source node to define its values and a target type. The selected attribute is not available to be mapped for the Source Attribute in the schema map table.</td>
</tr>
</tbody>
</table>
### Component | Function
--- | ---
Define Value [Table] | To define the values of selected attribute and the target type of each value. The table has the details as following:
- **Default**
  You need to specify the default target type. If an attribute value does not match any mapped values when copying data or creating relations, then DataHub will use the default target type.
- **Priority**
  It is used when a defined attribute has multiple values. The first target type on the list has the highest priority and will always be selected first in the mapping process.
- **Value**
  It allows you to select a value for a target type. If a selected attribute is an enumeration, you can choose the values from the drop-down list.
- **Target**
  It allows you to define a target type for a selected value.
Exclude all unmapped nodes from DHLink | To exclude all nodes that you select from data synchronization.
Quick search | To find a particular type containing specific text in real time.
Target Type tree | To show all types that are allowed to be added according to the type you have selected in a Data Type tree. The tree comes from the driver and a Cameo DataHub client shows the tree accordingly.
UNSPECIFIED | To un-map selected nodes in the Source tree. The color of unmapped nodes is red.
Set as default target type [Check Box] | To allow a Cameo DataHub client to create the same type of target when a source type is selected. If the map already exists in the system, the new target type will overwrite the old one and as a result, the Schema Map dialog will not open.
![Edit] [Button] | To edit a schema map by selecting the attributes in the provided schema map table.
![OK] [Button] | To start copying with the selected target type and schema map.
![Cancel] [Button] | To cancel a copy operation.

To copy data from DataHub Explorer to the MagicDraw® Containment tree:

1. Select (i) the Copy Data mode from the DataHub operation mode to copy data only, (ii) the Copy Data with Sync mode to copy data and create synchronization, or (iii) the Create OSLC Link mode to create OSLC links.
2. Drag a node from DataHub Explorer to an element in the Containment tree in MagicDraw®. The Copy Data dialog will open and show the mapping mode and options for mapping the source and target types.

**NOTE:** If you want to copy a DHLink (a MagicDraw® relation or a DOORS link), you have to copy all the parent nodes of this relation. If only one parent node is copied, the DHLink will not appear.

3. You can also drag a node from the DataHub Explorer to the MagicDraw® diagram pane. The dragged node will be displayed as an element, Figure 60. Any nodes that have not been mapped to a type in the target tool will be shown with a red circle.

![Figure 60 -- Dragging a Node to the MagicDraw Diagram Pane](image)

**NOTE:** You can use the MagicDraw® Layout menu to re-arrange or re-organize diagrams. From MagicDraw® main menu - click Layout > Quick Diagram Layout to get a properly arranged diagram.

4. To resolve an unmapped node (a node with a red circle), select it from the Source tree and choose a target type that is available on the list on the right side of the dialog.
NOTE

- DataHub supports stereotypes so if you have the same MagicDraw® data type with different stereotypes, you can map these two nodes using a different schema.
- You can also map custom stereotypes that you have created on your own. Once you have created the nodes, reload the data sources. The custom stereotypes will then become visible in the DataHub Explorer.
5. You can select the **Set as default target type** check box so that your nodes will be automatically mapped to these target types for the same type of data, without mapping them again in the **Copy Data** dialog.

**NOTE** You cannot **Set as default target type** with the same target type at the same time. If you **Set as default target type** with multiple source types, DataHub will set the new one as the default target type.

6. To map a source attribute with a target attribute, click the cell of the target attribute to be mapped with the source attribute and select the target attribute from the drop-down menu. Once the type and attributes have been mapped, the color of the circle on the source node will change from red to green.

7. Continue mapping all the types of the source node, and then click **OK** to copy them.

**NOTE**
- The **Copy Data**, and **Copy Data with Sync**, modes use the default templates in the Schema Map Manager. Thus, if you need to map a source node with other element types, you need to edit the default schema map.
- DataHub supports mapping multivalued attributes by using the multiplicity of models. Therefore, if you map the multiple attribute values to the multivalued target attributes, you need to create custom stereotypes and properties to apply to the particular target nodes.
- To map the source node’s attribute to the multivalued attribute of the target node, you need to select the target node that has applied the stereotype node and select the stereotype property.

8. When the data has been copied successfully, the **Copy Data Summary** dialog will open and show a list of all copied data Figure 62.

**NOTE** If you select the **Copy Data** operation mode, DataHub allows you to leave unresolved nodes when copying data. However, if you select the **Copy Data with Sync** operation mode, you need to map all nodes in order to maintain the data hierarchy; or select the **Exclude** option to ignore any unmapped nodes.
To copy data or create a DHLLink from a Data Source within DataHub Explorer:

1. You can select (i) the **Copy Data** mode from the DataHub operation mode drop-down to copy data only, (ii) the **Copy Data with Sync** mode to copy data and create synchronization links, or (iii) the **Create OSLC Link** mode to create OSLC link relations.
2. Drag a node from any **Data Source** to a node within **DataHub Explorer**, Figure 63. Either the source or target node must be a MagicDraw® node.

3. The **Copy Data** dialog will open, prompting you to choose between Individual and Group type mapping modes. Choose a mode and then map the source types to appropriate target types. Click **OK**.
To copy data from a CSV Data Source:

1. Select either (i) the Copy Data mode from the DataHub operation mode drop-down to copy data only or (ii) the Copy Data with Sync mode to copy data with synchronization.

   ![Cameo DataHub Explorer](image)

   **Figure 64 -- Copying from a CSV Data Source**

2. You can select and copy multiple nodes and their sub-nodes to the CSV Data Source by dragging them. Once you have dragged the nodes to the CSV Data Source, a dialog will appear asking whether you want to add the nodes recursively. Select No to copy the nodes without data hierarchy or Yes to copy the nodes along with synchronization details.
3. The Copy Data dialog will open and you have to choose between **Individual** and **Group Type Mapping** mode. Choose a mapping mode and then map the source types to appropriate target types.

### NOTE
- A CSV Data Source supports the **Copy Data with Sync** operation and DataHub excludes all child nodes for CSV automatically since a CSV file has no data hierarchy.
- You cannot copy links (a MagicDraw® or a DOORS link) to a CSV Data Source since links always have data hierarchy with their parent nodes.
- You will not be able to synchronize relations with a CSV data source if you change the attribute synchronized with a CSV key field. This is because DataHub uses the CSV key field to indicate the synchronization target.

### 3.8.2 Copying Requirements into MagicDraw®

#### 3.8.2.1 Copying Requirements to MagicDraw® as SysML Requirement Diagram

Text based requirements and their associated use cases can be copied from DOORS or DOORS Next Generation data sources by simply dragging and dropping the node from the DOORS data source to MagicDraw® containment tree.

This section deals with how to copy text based requirements from IBM® Rational® DOORS® into a MagicDraw® diagram.

To copy requirements from DOORS data source to MagicDraw® as SysML Requirement Diagram:

1. Have a DOORS or DOORS Next Generation data source ready in DataHub explorer.
2. Click to select a node and then drag it from DataHub explorer to MagicDraw® containment area.
3. Map the formal module to a package and the object to a base stereotype of **requirement**, Figure 65 and Figure 66. Click **OK**.
4. Figure 67 shows the results of the copy.
Figure 65 -- Map Formal module requirements to SysML requirements diagram
Figure 66 -- Map object to base type of requirement
3.8.2.2 Copying Requirements to MagicDraw® as Use Case Diagram

This section deals with copying a Use Case diagram from a DOORS data source into MagicDraw® containment area.

To copy a use case from DOORS data source to a MagicDraw® as Use Case Diagram:

1. Have a DOORS or DOORS Next Generation data source ready in DataHub explorer.
2. Drag the selected node from DOORS data source to MagicDraw® containment tree, Figure 68. Map the formal module to a use case diagram type and the object to a use case type, Figure 69 and Figure 70.
3. A use case diagram should now appear in the MagicDraw® diagram area, Figure 71.
Figure 68 -- Drag and drop to copy requirements from DOORS data source to MagicDraw
Figure 69 -- Mapping DOORS Formal module as Use Case diagram
Figure 70 -- Mapping DOORS object as Use Case
3.8.2.3 Copying Requirements to MagicDraw® with DataHub Link

To copy requirements from DOORS, or DOORS Next Generation data source to MagicDraw®

1. Select **Copy Data with Sync** mode from the DataHub operations mode drop-down.
2. Drag and drop a node from DataHub explorer to MagicDraw® containment tree, Figure 71.
3. The result of the copy is shown in Figure 73.
3.8.2.4 Copying Requirements to MagicDraw® with OSLC Link

This version of DataHub now supports OSLC queries and links.
To copy requirements using OSLC links

1. Select the **Create OSLC Link** mode from the DataHub operations mode drop-down.
2. Drag a node from the DataHub explorer to the MagicDraw® containment tree, a popup prompting you to select the type of link will appear as in Figure 74. Select one from the list.
3. The result of copying requirement using OSLC link is shown in Figure 75.

![Figure 74 -- Copying requirement using OSLC Link](image)
3.9 Synchronizing Requirements

Data synchronization is the process of sending all changes in the attribute values including a list of deleted items from a source to a target data. Either the source or target must be a MagicDraw® node.

Data synchronization allows you to maintain consistency of data across nodes in different data sources or applications. During synchronization, all types of changes in a data source or an application will be stored in the DHLink map which is stored along with the project in its repository.

In addition to the Synchronize command on the DataHub Actions menu, DataHub also provides the synchronization option through the DataHub main menu and the icons in the Containment tree and DataHub Explorer.

Data synchronization can be categorized into two functional types: (i) data source synchronization, and (ii) node synchronization.

Synchronization is to synchronize all items that have DHLink in a current project in an application. An entire Data Source can be synchronized with Synchronization.

Node Synchronization allows you to synchronize a specific node using either:

(i) Synchronize Node or

(ii) Synchronize Node Recursively.

Data synchronization depends on the selected node. DataHub ignores all excluded nodes in the Sync relations during data synchronization.

You can perform synchronization on a selected node by clicking the synchronize button on the DataHub explorer toolbar, Figure 76.
Figure 76 -- Synchronizing a Data Source using the Synchronize button in DataHub explorer

Alternatively, you can perform synchronization from the MagicDraw® main menu by clicking **Tools > DataHub > Synchronize** as shown in Figure 77.
3.9.1 Data Source Synchronization

You can synchronize a data source by selecting it and clicking either the **Synchronization** button on the DataHub explorer toolbar or by choosing the **Synchronize** menu item from the context menu.

To synchronize an entire data source:

1. Select a data source in the DataHub Explorer tab and click the **Synchronization** icon in DataHub Explorer, Figure 78.
2. Or right-click a data source and select the **Synchronize** menu, Figure 79. All items that have **DHLINK** with the selected data source will be synchronized.

**NOTE**

The **Synchronize** icon in DataHub Explorer will be enabled once you select a node or a data source.
3.9.2 Node Synchronization

Node Synchronization allows you to select a particular node that you want to synchronize. There are two ways to synchronize a node: (i) Synchronize Node and (ii) Synchronize Node Recursively.

When you select a node and select Synchronize Node, DataHub will synchronize only the selected node. The Synchronize Node Recursively command will synchronize a selected node and its child nodes. After selecting a node that you want to synchronize, choose one of the following procedures indicated below to complete the node synchronization.
WORKING WITH DATAHUB IN MAGICDRAW
Synchronizing Requirements

(i) To synchronize data with node synchronization on MagicDraw® main menu:

1. Select a node to synchronize and click **Tools > DataHub > Synchronize**.
2. Select either (i) **Synchronize Node** or (ii) **Synchronize Node Recursively**, Figure 80.
3. This will render the data source on the MagicDraw® side as the master data source.

(ii) To synchronize data with node synchronization through the context menu:

1. Right-click a node to synchronize and click **Synchronize**, Figure 81.
2. If the selected node is on the MagicDraw® side, that will become the master data source, and if the selected node is on the DataHub Explorer, then that will become the master data source.

The **Data Synchronization Confirmation** dialog will always open and ask for a confirmation whenever you synchronize data. You can disable this dialog through the DataHub **Options** menu or by selecting the **Do not show this dialog again** check box in Figure 82 below.
3.9.3 Conflict Dashboard

The Conflict dashboard lists all the nodes that have either been changed, moved, deleted, or excluded. A simple color scheme enables you to differentiate between them.

To access the Conflict Dashboard:

1. Right-click a node and choose Check Node Changes or Check Node Changes Recursively.
2. If there are any changes, the Conflict Dashboard will appear, not otherwise.

**NOTE** Conflict Dashboard will appear only when you perform Check Node Changes or Check Node Changes Recursively at any data source except a MagicDraw® data source.
3.9.3.1 Comparing Conflicted Requirements

The Conflict Dashboard dialog allows a user to compare conflicting requirements. Figure 83. See the different colors for different sync statuses.

3.9.3.2 Synchronization Status

DHLink Panel shows unresolved nodes that need synchronization and a colored half square triangle icon represents the Sync status. Each color represents a different Sync status. Conflict Dashboard also shows the unresolved node statuses and they’re colored the same, Figure 83.

3.9.4 Directions of Synchronization

There are three possible directions of data synchronization: (i) Two-way Sync, (ii) Source to Target only, and (iii) Target to Source only. The synchronization direction allows you to choose the direction from which the changes will be sent. The direction determines whether synchronization is to be done from source to target, target to source, or both. A source node is the node that you drag and a target node is the node you create from dragging the source node.

(i) Two-way Sync

Two-way Sync enables you to sync to a relative node in both directions; from the source to the target and vice versa.
(ii) Source to Target only

Source to Target only means that you can sync from a source to a node in an opposite direction. This type of synchronization cannot detect changes in the Target and therefore they will not be synchronized.

(iii) Target to Source only

Target to Source only means you can sync from the Target only. If you need to synchronize changes that exist in the source node to the target, you will need to change the direction of synchronization first.

3.10 Mapping Requirements

3.10.1 Mapping with the Schema Map Manager

The Schema Map Manager dialog allows you to see all attributes of both Source and Target. It automates data matching and mapping so that you can integrate data on both sides and make them identical.

To open the Schema Map Manager dialog in MagicDraw®:

1. Click Tools > DataHub > Schema Map Manager.
2. The Cameo DataHub Schema Map Manager dialog will open Figure 84. Expand the nodes to see the types that have already been mapped.
You can also select a schema map template provided in the **Schema Map Manager** dialog. You can expand each Data Source to see the template.

DataHub allows you to view a schema map that has been used by a particular relation Figure 85. You can right-click an item in the table and select **View Schema Map** to open the **View Schema Map** dialog.
3.10.2 Schema Mapping Modes

You can map nodes by using either the (i) Simple Schema mapping mode or (ii) Define Target Type from Attribute Value mapping mode.

3.10.2.1 Simple Schema Mapping

Updating an existing schema map in the Schema Map Manager dialog is an example of simple mappings between data in the source schema and the target schema. You can define a target type from the attribute value mappings through the Define Target Type from Attribute Value dialog. For more detail about defining target type from the attribute values, see section 3.10.2.2 Define Target Type from Attribute Value Mapping.

If your previous mapping mode is define target type from attribute value mapping then it will be set as a default mapping automatically. You can change the default to a simple mapping so that you can use it to copy data when the define target type from attribute value mapping mode is disabled.

To specify a default mapping:

1. Open the Cameo DataHub Schema Map Manager dialog.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section, Figure 86.
3. Click a Target Type.
4. Click the Set as Default button. The button text will change to Remove Default.
To remove a default mapping mode:

1. Open the \textit{Cameo DataHub Schema Map Manager} dialog.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section, Figure 87.
3. Click a Target Type.
4. Click the \textit{Remove Default} button. The button will change to \textit{Set as Default}. 

\textit{Figure 86 -- Selecting Default Schema Map}
To edit a schema mapping:

1. Open the **Cameo DataHub Schema Map Manager** dialog.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section.
3. Click a Target Type. The default attributes mapping list will open.
4. Click the **Edit** button to enable editing mode, Figure 88.

**Figure 87 -- Removing Default Schema Map**
5. Change the attributes mapping, and then click **Save**.
6. If the edited schema map has been used then the **Edit Schema Map Confirmation** dialog will open Figure 89.
7. Click (i) **Yes** to confirm that you want to edit the schema, (ii) **No** to cancel it, or (iii) **Details** to see all affected nodes.
3.10.2.2 Define Target Type from Attribute Value Mapping

The Define Target Type from Attribute Value mapping is another copy and synchronization capability of DataHub to locate or find a node’s type in the target so that you can map a node’s type from the source to the target correctly. If your previous mapping mode is the define target type from attribute value mapping, it will be used as the default mapping mode automatically. You can update the target types and attribute values in the Define Target Type from Attribute Value dialog.

Enabling the Define Target Type from Attribute Value Mapping

If you previously mapped a schema and copy data using the Define Target Type from Attribute Value mapping mode, the next time you open the Cameo DataHub Schema Map Manager dialog with similar data, you will have the same mode open as the default mapping mode automatically. Therefore, the Export Schema Map Wizard dialog will no longer open the next time you copy data. If you do not want to map in this mode, you can click the Deactivate button to disable the define target type from attribute value mapping mode in the Cameo DataHub Schema Map Manager dialog.

To disable the Define Target Type from Attribute Value mapping mode:

1. Open the Cameo DataHub Schema Map Manager dialog.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section.
3. Click a Target Type. The default attributes mapping list will open, Figure 90.
4. Click Deactivate to disable the Define Target Type from Attribute Value mapping mode and the button will change to Activate.

To enable the Define Target Type from Attribute Value mapping mode:

1. Open the Cameo DataHub Schema Map Manager dialog.

NOTE DataHub will save an edited schema map that has been used and it will be effective as soon as you perform data synchronization.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section.
3. Click a Target Type. The default attributes mapping list will open.
4. Click **Activate** to enable the **Define Target Type from Attribute Value** mapping mode, and the button text will change to **Deactivate**.

**Figure 90 -- Activate/Deactivate Define Target Type from Attribute Value Mapping Mode**

**Updating the Define Target from Attribute Value Mapping**

You can add, remove, or change the priority of a target type as high or low priority, and update the attribute mappings through the **Define Target Type from Attribute Value** dialog.

To update an existing define target type from attribute value mapping:

1. Open the **Cameo DataHub Schema Map Manager** dialog.
2. Select a Source Type whose mapping you want to edit. The default target type will open in the Target Type section.
3. Click a Target Type. The default attributes mapping list will open.
4. Click **Edit**, and the **Define Target Type from Attribute Value** dialog will open, Figure 91.

![Figure 91 -- Updating an existing Define Target Type from the Attribute Value Mapping mode](image)

5. Edit or update the mapping values, and then click **Save**.

### 3.10.3 Exporting a Schema Map

Once you have copied some data with types and attributes mappings, DataHub will keep the mappings between the types and attributes. If you set them as the default mappings then DataHub will map the source node with the target node automatically the next time you copy data or create DHLinks. You can edit those mappings later in the **Schema Map Manager** dialog.

With the Export Schema Map wizard, you can export an existing schema map to an XML file format. You can select a particular schema map from a data source in the selected driver.

**To export a schema map:**

1. Open the **Cameo DataHub Schema Map Manager** dialog and click **Export**. The **Export Schema Map Wizard** dialog will open, Figure 92.
2. Select the Source and Target data source whose mapping you want to export, and then click **Next**.

3. Select the data types whose mapping you want to export, and then click **Next**, Figure 93.

---

*Figure 92 -- Export Schema Map Wizard Dialog*
4. Type the name and description of the schema map, Figure 94.
5. Click the “...” button to select a location to save the file.
6. Click Finish to export the schema map, Figure 94.
3.10.4 Importing a Schema Map

You can import a schema map that is in the XML format to DataHub.

To import a saved schema map:

1. Open the Cameo DataHub Schema Map Manager dialog and click the Import button.
2. Select a schema file to be imported, and then click Open.

3.10.5 Deleting a Schema Map

If a schema map is referenced by a DHLink it cannot be deleted. Only schema maps that are not referenced by any DHLink can be deleted. Deleting a Define Target Type from an Attribute Value mapped schema will cause all defined target types to be deleted. But if you just want to delete some values of the schema, then you can delete them in the Define Target Type from Attribute Value dialog.

To delete an existing schema map:

1. Open the Cameo DataHub Schema Map Manager dialog.
2. Select a Source Type whose mapping you want to delete. The default target type will open in the Target Type section Figure 95.
3. Click **Delete**. A confirmation message will open. Figure 95.

4. Click **Yes**.

If you delete a schema map that is currently in use, an error message will open. It means that one or more relations are using the schema map that you want to delete; therefore, you must delete the relations first and then delete the schema map.

### 3.11 Working with an Alias

DataHub Explorer can contain a very long and deep tree hierarchy. However, you can select only the section that you want to work with and open it as a root node in an Alias Explorer. You can view or open an Alias you have created through Alias Manager.
3.11.1 Alias Explorer

To create an Alias Explorer:

- Right-click a node that you want to scope and click Create Alias, Figure 96. An Alias Explorer tab will open, showing only the section that you have selected.

![Figure 96 -- Creating an Alias](image)

3.11.2 Alias Manager

Once an Alias has been created, it will be saved in Alias Manager even though the Alias Manager tab is not open. You can reopen or remove an Alias you have created through the Alias Manager dialog.

To manage an existing Alias:

2. The Alias Manager dialog will open, Figure 97. Expand each Driver to see all of the Aliases under each Driver.
3. Select one or more Aliases.
4. Click either (i) Open to open the selected Alias or (ii) Remove to delete it.

NOTE: The created alias will be displayed in Alias Manager only if the related data source is connected.
Figure 97 -- Alias Manager Dialog
3.12 Working with DHLink Summary and Generating Report

3.12.1 DHLink Summary

If you have many DHLink and you want to review them, you can select DHLink Summary from the DataHub menu to open the Cameo DataHub DHLink Summary dialog and view all types of links Figure 98. In the DHLink Summary dialog, you can filter the relations that you want to view and adjust the display. You can also remove a relation, update it, or clear the status.

There are two filter options: (i) No DHLink and (ii) DHLink. The No DHLink option will filter all elements that have no DHLink element in the DataHub and the DHLink option will filter all elements that contain a DHLink Synchronization.

To open the DHLink Summary dialog:

1. Click Tools > DataHub > DHLink Summary on the MagicDraw® main menu.
2. The DHLink Summary dialog will open, Figure 98. The Filter Options pane on the left-hand side allows you to choose what types of relations you want to see. You can select either:

   (i) No DHLink to display independent standalone elements and nodes without any DHLink.

   (ii) DHLink to display the relation between elements. If you select the DHLink button, the Data Sync Scope and Trace options will be enabled.

3. You can select any check box that represents the driver and data source to open them in the to-be generated DHLink summary.
4. Click View. The DHLink summary will open on the right-hand side of the dialog.
Table 16 below provides the description of each column in the **DHLink Summary** dialog.
Working with DHLink Summary and Generating Report

### 3.12.2 Direction of DHLink

Besides showing the source and type elements that have DHLink, and the types of the DHLink, the DHLink Summary dialog also displays the direction of the DHLink with an arrow. The arrow describes the direction of synchronization graphically, either unidirectional or bidirectional.

Table 17 below explains the meaning of the arrows and the directions of DHLink and sync status they represent.

#### Table 17 -- Arrows to represent directions of Relations and Sync Status

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Type</th>
<th>Sync Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Two-way sync" /></td>
<td>Two-way sync</td>
<td>Synchronized</td>
<td>Data synchronization can be performed at both sides, source or target with the <strong>Synchronized</strong> status.</td>
</tr>
<tr>
<td><img src="image" alt="Source to Target" /></td>
<td>Source to Target</td>
<td>Synchronized</td>
<td>Data synchronization can be performed only from the source with the <strong>Synchronized</strong> status.</td>
</tr>
<tr>
<td><img src="image" alt="Target to Source" /></td>
<td>Target to Source</td>
<td>Synchronized</td>
<td>Data synchronization can be performed only from the target with the <strong>Synchronized</strong> status.</td>
</tr>
<tr>
<td><img src="image" alt="All" /></td>
<td>All</td>
<td>Pending Update/Pending Delete</td>
<td>The relation status is <strong>PendingUpdate</strong> or <strong>PendingDelete</strong> and the data will be updated from the source to the target.</td>
</tr>
<tr>
<td><img src="image" alt="All" /></td>
<td>All</td>
<td>Pending Update/Pending Delete</td>
<td>The relation status is <strong>PendingUpdate</strong> or <strong>PendingDelete</strong> and the data will be updated from the target to the source.</td>
</tr>
<tr>
<td><img src="image" alt="All" /></td>
<td>All</td>
<td>Excluded</td>
<td>This symbol is used for a Scope Sync relation that has been excluded and has a virtual relation.</td>
</tr>
</tbody>
</table>
3.12.3 DHLink Summary Dialog Context Menu

The DHLink panel provides a context menu that allows you to

- Remove DHLink
- Select in Application
- Select in DataHub/Alias Explorer

To open the context menu:

1. Right-click a value in the element in the DHLink Summary dialog. The context menu will open, Figure 99.

![DHLink Summary Dialog Context Menu](image)

**Figure 99 -- DHLink Summary Dialog Context Menu**

<table>
<thead>
<tr>
<th>Menu</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Direction</td>
<td>This context menu item changes the direction of synchronization. Available options are <strong>Two-way Sync</strong>, <strong>Source to Target only</strong> and <strong>Target to Source only</strong>.</td>
</tr>
<tr>
<td>Remove DHLink</td>
<td>Removes the selected DHLink from both of the associated nodes.</td>
</tr>
<tr>
<td>Select in Application</td>
<td>Selects the node that a DHLink belongs to in its original application.</td>
</tr>
<tr>
<td>Select in DataHub/Alias Explorer</td>
<td>To select a node from DataHub or Alias Explorer.</td>
</tr>
</tbody>
</table>

For Pending Update and Pending Delete data nodes, there are additional menu items as in Figure 100.
WORKING WITH DATAHUB IN MAGICDRAW

Working with DHLink Summary and Generating Report

Table 19 below describes the function of each of these menu items.

Table 19 -- DHLink Panel context menu for pending update and pending delete data nodes.

<table>
<thead>
<tr>
<th>Context Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Schema Map</td>
<td>Opens the Schema Map Manager dialog.</td>
</tr>
<tr>
<td>Update Pending DHLink</td>
<td>Synchronizes the node by updating the pending DHLink.</td>
</tr>
<tr>
<td>Discard Update</td>
<td>Synchronizes the node by discarding the DHLink.</td>
</tr>
<tr>
<td>Exclude Node</td>
<td>Excludes the node from being included for synchronization.</td>
</tr>
<tr>
<td>Remove DHLink</td>
<td>Removes the DHLink reference.</td>
</tr>
<tr>
<td>Select in Application</td>
<td>This selects the DH linked Node in the Application, if it is DOORS, the DOORS client will activate, with that node selected.</td>
</tr>
</tbody>
</table>

3.12.4 Saving DHLink Summary as Report

Click **Tools > DataHub > DHLink Summary** to open the **DHLink Summary** dialog shown below. After you view a **DHLink Summary**, you can click the **Save** button to save the summary view, Figure 98. The report will be saved in HTML format so that you can open it in a web browser such as Chrome or Firefox.

To save a **DHLink Summary** as a report:

1. Select the filter options for the **DHLink Summary**.
2. Save it as a report by clicking either:
   - (i) the **View** button to view the DHLink Summary, and then click the **Save** button to save the summary as a report.
   - (ii) the **Generate** button to save it as a report without viewing the items in the **DHLink Summary**.
To generate a large amount of report data faster, we recommend that you use the **Generate** button.
DataHub plug-in is a plug-in for IBM® Rational® DOORS® clients.

The DataHub menu is available for the following items: (Figure 99)

- Synchronize
- Create Alias from Current Location
- About

4.1 DataHub Main Menu in DOORS

The DataHub has two menus in IBM® Rational® DOORS®, a main menu item and a context menu item.

4.1.1 Opening DataHub Main Menu in DOORS Client

After installing the DataHub plug-in for IBM® Rational® DOORS®, the DataHub main menu in the DOORS client will be enabled.

To start the IBM® Rational® DOORS® Client, click the executable or go to Programs and start the DOORS client from there.

**Note**

If you change the DataHub build version in MagicDraw®, the DataHub Driver Deployment must be executed. If not, then the DOORS, DataHub menu may not appear.

To view the DataHub menu item from the DOORS client:

1. Start the DOORS Client by logging in with your username and password.
2. Click DataHub on the DOORS Client main menu, Figure 99.
Once you have started the DOORS driver, it will connect to DataHub automatically. The DataHub main menu provides some functions that you can perform with the DataHub as shown in Table 19 below.

**Table 19 -- DataHub Menu and Functions in DOORS Database**

<table>
<thead>
<tr>
<th>Name</th>
<th>Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronize</td>
<td>To synchronize a project from a DOORS Data Source.</td>
</tr>
<tr>
<td>Create Alias from Current Location</td>
<td>To create an IBM® Rational® DOORS® alias from the selected items to be used in MagicDraw®.</td>
</tr>
<tr>
<td>About</td>
<td>Opens the About dialog.</td>
</tr>
</tbody>
</table>

### 4.1.2 DataHub Shortcut Menu

The DataHub shortcut menu is available for the selected objects in the DOORS formal module, Figure 100.
Table 20 below describes the functions in the DataHub shortcut menu.
4.2 Working with DataHub in IBM® Rational® DOORS®

4.2.1 Starting the DOORS Client

Before you can perform any DataHub operations like setting up an IBM® Rational® DOORS® data source, you need to start the DOORS client application, as well as deploy the DOORS driver from DataHub menu. Once that is done, you can create a DOORS data source in MagicDraw® DataHub explorer tab. If the DOORS client is not started then MagicDraw® will display an error dialog saying it cannot connect to DOORS client.

To start the DOORS Client:

1. Click the IBM® Rational® DOORS® program icon or start it from programs menu.
2. Once you log into the DOORS Client, you can connect to DOORS from DataHub.
3. You can now create a DOORS data source from MagicDraw® DataHub explorer tab.

Note: If you reload the DOORS data source, the DOORS application will auto-run.

4.2.2 Synchronizing Data

You can synchronize data from the DataHub menu. DataHub will synchronize data and update all pending changes from the DOORS side.

To synchronize data from the DataHub menu:

1. Open the DataHub menu in DOORS client.
2. Select Synchronize to synchronize and update all pending changes, except create new node without default.
3. Or select Synchronize option from context menu.

| NOTE | The Synchronize New Node dialog will not appear when you click Synchronize. Therefore, any new created nodes with DHLink will be discarded. However, you can synchronize the project in the DataHub Explorer in MagicDraw® to solve this issue. |

### 4.2.3 Creating an Alias

You can create an alias in DOORS to be displayed in MagicDraw®. If you create the alias through the DOORS database menu, DataHub will use the current location as the root node. Alternatively, if you create the alias through the DOORS Formal Module menu, DataHub will use the current module as the root node in the Alias Explorer. You can see and manage the created alias only in MagicDraw® (see 3.11 Working with an Alias).

To create an alias:

1. Open DataHub menu either in DOORS database, see 4.1.1 Opening DataHub Main Menu in DOORS Client.
2. Select Create Alias from Current Module on the main menu of DOORS Formal Module.
DataHub supports local and remote connections. A local project is a project that is stored on your machine. When you connect to Teamwork Server, the other users can remotely see the project you are working on through the server. Multiple users can collaborate and work on the same project concurrently and the DHLink map will be stored along with the project on the Teamwork Server. This allows all users to see other users' changes.

In addition to local and remote connections, DataHub also provides functionality that allows several users to access one Data Source and work on the same project including the DataHub relations at the same time. This functionality is available for projects that are stored on the Teamwork Server.

### 5.1 Data Source on Teamwork Server

Data Sources in DataHub can be categorized into two types: (i) local data source and (ii) Teamwork data source.

A **Local Data Source** is a data source that exists in a client's computer and is not used by any other clients in the Teamwork server. A **Teamwork Data Source** is a data source that references a MagicDraw® project on the Teamwork server. A **Teamwork Data Source** is accessible to more than one client.

#### 5.1.1 Teamwork Data Source

A **Teamwork Data Source** creates a local data source from the same repository server and can be identified as the same data source for different clients. Since the DHLink map detail is stored along with the project details on the Teamwork Server, all clients can see and receive each others changes, provided they update before commit.

The project will be treated in compliance with the Teamwork Server rules. For instance, you need to log on to the Teamwork server first and check out the items that you need to work on. For more information about Teamwork Server, see Chapter 12 Working with Teamwork Server in the MagicDraw® User Guide.
5.1.1.1 Updating Teamwork Data Source

A DataHub project in a Teamwork Data Source, which is opened through Teamwork Server, is accessible to multiple clients. When multiple clients are working on the same Teamwork project that contains **DHLink** at the same time, DataHub will show the project and the number of clients that are using it under a single Data Source in DataHub Explorer. The Data Source will show the project that is currently open on each client's machine.

You can add a Teamwork Data Source to the DataHub explorer. You can work on the data source and save the changes. The other users can also do the same things you do to the same project. Therefore, the project in a teamwork data source may contain different sets of data as a result of multiple updates.

As long as all clients update before committing, no conflicts will occur because the **DHLink** map is stored on the Teamwork Server along with all the project details.

| NOTE | For more details about setting Teamwork in MagicDraw®, see the MagicDraw® user guide. |

(ii) To log on to Teamwork Server:

1. On the MagicDraw® main menu, click **Collaborate > Login**. The **Login** dialog will open, Figure 102.
2. Enter all the server connection parameters.
3. Click **OK**.
Figure 102 -- The Login Dialog of Teamwork Server in MagicDraw®

Table 21 below explains about each connection parameter in detail.
Table 21 -- Connection Parameters of the Teamwork Server

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>User name</td>
<td>To specify a username to connect to Teamwork server.</td>
</tr>
<tr>
<td>Password</td>
<td>To specify a password to connect to Teamwork server.</td>
</tr>
<tr>
<td>Server name</td>
<td>To specify a Teamwork server name or IP Address.</td>
</tr>
<tr>
<td>Auto Login to Server</td>
<td>To log on to Teamwork server automatically once MagicDraw® starts.</td>
</tr>
<tr>
<td>Use Secured Connection (SSL)</td>
<td>Turn on SSL encryption for data transfer.</td>
</tr>
<tr>
<td>OK</td>
<td>To confirm the connection parameters and log into Teamwork server.</td>
</tr>
<tr>
<td>Cancel</td>
<td>To cancel the login process.</td>
</tr>
<tr>
<td>Help</td>
<td>To open the Help dialog.</td>
</tr>
</tbody>
</table>

To open Teamwork projects:

1. On the MagicDraw® main menu, click **Collaborate > Open Server Project.** The **Open Server Project** dialog will open, Figure 103.
2. Select a particular project and click **Open.** MagicDraw® will open the selected project.
Figure 103 -- the Open Server Project Dialog
**NOTE:**

- All users must connect to Teamwork Server using the same host address (IP address or machine name).
- DataHub handles the items in a data source in compliance with the Teamwork Server rules.
Appendix A

Terminology

This section explains some of the terminology used throughout this user guide.

**Alias**

Alias is a name that is assigned to a node in the DataHub explorer tree or MagicDraw® containment area tree. This node can then be accessed or removed via the Alias Manager dialog.

**Artifact**

An artifact is one of many kinds of tangible by-products produced during the development of software. Some artifacts (e.g., use cases, class diagrams, and other Unified Modeling Language (UML) models, requirements and design documents) help describe the function, architecture, and design of software. Other artifacts are concerned with the process of development itself—such as project plans, business cases, and risk assessments.

**Bidirectional**

This is source to target link. A bidirectional link will update both source and target nodes.

**Data**

Data refers to an item whose specific format enables it to be synchronized with and referenced to and from another data. Data can be a MagicDraw® element or relation, a DOORS node or relation, or a CSV row.
Data Source

A data source refers to the project path of an application. A data source can be any of the following:

- MagicDraw® project
- IBM® Rational® DOORS® Client
- IBM® Rational® DOORS® Next Generation Client
- CSV file

An application can have more than one data source. Each data source refers to a specific project path and has a unique Data Source ID.

You can connect DataHub to the following applications: (i) MagicDraw®, (ii) IBM® Rational® DOORS®, (iii) IBM® Rational® DOORS® Next Generation, and (iv) data repository in CSV format.

Node

A node is like a leaf in a tree. It represents a distinct point within the tree structure. A node can have children or be a child itself.

DataHub Operation Mode

You can use DataHub operation mode to copy data, copy data with sync, or create OSLC Link. Table 22 below describes the function of the DataHub operation mode.
Table 22 -- DataHub Operation Mode

<table>
<thead>
<tr>
<th>Operation Mode</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy Data</td>
<td>To copy data without creating any DHLink.</td>
</tr>
<tr>
<td>Copy Data With Sync</td>
<td>To copy data and create the DHLink which is used for synchronization.</td>
</tr>
<tr>
<td>Create OSLC Link</td>
<td>Creates OSLC Link</td>
</tr>
</tbody>
</table>

OSLC

DataHub, as of this version facilitates OSLC queries. Open Services for Lifecycle Collaboration (OSLC) is an open community creating specifications for integrating tools. The goal of OSLC is to create specifications for interactions between tools.

In OSLC, each artifact in the lifecycle – for example, a requirement, defect, test case, source file, or development plan and so on – is an HTTP resource that is manipulated using the standard methods of the HTTP specification (GET, PUT, POST, DELETE).

OSLC Query

DataHub supports two types of OSLC queries - basic query and advanced query. The basic query is a simple text based search while the advanced query syntax follows SQL or SPARQL.

OSLC Link

The OSLC specification defines relationships and that relationships should be modeled as links.

The types of unidirectional links that are supported include affectedBy, constrainedBy, constrains, decomposedBy, decomposes, elaborates, elaboratedBy, implementedBy, satisfiedBy, among others.

Module

A DOORS container within which hierarchically arranged sub-modules may be contained, typically, this is a requirement specification tree.
Relationship

A relationship is said to exist between two resources if there is something that connects them; they work together, belong together, are similar or should be considered together. There may be different types of relationships.

System Model

A system model is the conceptual model that describes and represents a system. A system is comprised of multiple views such as planning, requirement (analysis), design, implementation, deployment, structure, behavior, input data, and output data views. A system model is required to describe and represent all these multiple views.

Requirements Traceability

Requirements traceability is concerned with documenting the life of a requirement and providing bidirectional traceability between various associated requirements. It enables users to find the origin of each requirement and track every change that was made to this requirement.

Requirements are realized into design artifacts, implementation, and are finally verified, the artifacts tied to the latter stages should be traced back to the requirements as well. This is typically done via a Requirements Traceability matrix.

Link

A link is a URI reference from one resource, the subject or source, to another resource, said to be the object or target. In RDF and in OSLC we use links to model relationships and like relationships, links are unidirectional.

DataHub Tree

A DataHub tree refers to a tree structure designed to show drivers, data sources, and items of the connected data sources in DataHub. The tree within DataHub Explorer has two top levels: DataHub, and data sources respectively as DataHub itself consists of four drivers (MagicDraw®, DOORS, and DOORS Next Generation and CSV) and each driver has one or more data sources, except DOORS.
Driver

A driver refers to either a connector to an application or a connector to a file. Each driver has a unique Driver ID. There are three applications (MagicDraw®, DOORS, and Excel), and one data repository in CSV format, and each uses a specific driver. For example, the DOORS driver connects to DOORS and DOORS Next Generation driver connects to DOORS Next Generation.

Global ID

A Global ID consists of a Driver ID, a Data Source ID, a Type ID, and an Item ID arranged in that order and separated by a delimiter “/”. Each item or item type in the DataHub tree has a unique Global ID.

Item

An item refers to a particular element in the DataHub tree. Each item has a unique Item ID. Elements such as drivers, data sources, folders, packages, DOORS formal modules, requirements (data), and relationships (links) in the DataHub Explorer tree are called items. A node may have nested children as items.

Data refers to an item whose specific format enables it to be synchronized with and traced to and from another data (see "Data" above).

A link is an item whose specific format makes it possible to link one data to another and also enables it to be synchronized with other links (see "Link" below).

Item Type

An item type consists of a list of properties, for example, a SysML Requirement type consists of two properties (ID and Text). Thus, every item with the same item type shares the same property list. An item type can be a driver type, a data source type, an IBM DOORS requirement type, a MagicDraw® stereotype, or a CSV column. Each item type has a unique Type ID.

Link

A link is an item whose specific format makes it possible to link one data to another and also enables it to be synchronized with other links. A link can only be a MagicDraw® relationship, an IBM® Rational® DOORS® link, or an OSLC Link. Unlike data, links can only be synchronized.
Recursively

When this option is chosen, all the child nodes under the selected node will be included. If not, then only a single element will be processed.

Synchronized

Synchronized refers to the status of relations that the related nodes need to be the same as the other side.

Excluded

Excluded refers to the status of an ignored node only in Sync relations. The excluded nodes depend on the Sync relation that means one node can have both Excluded and other synchronization status.

Orphan

Orphan refers to the status of an updated item that attempts to synchronize to the other side of the relation that has been deleted.

PendingDelete

PendingDelete refers to the status of an item that occurs because one or more related items have been deleted. Pending delete status is similar to Orphan status, only it occurs at synchronization.

PendingUpdate

PendingUpdate refers to the status of an item that occurs because one or more related items have been updated (changes have been made to the item(s)). Items in PendingUpdate status can be either accepted to update the properties or discarded.

Sync Relation

DHLLink synchronizations are associations between data in both source and target items. Items with DHLLink can synchronize one another. DHLLink synchronization is available in the operation mode box in DataHub Explorer.
There are two kinds of DHLink: (i) unidirectional and (ii) bidirectional.

(i) Unidirectional is either from source to target or vice-versa. Data is synchronized in only one direction and not both directions.

(ii) Bidirectional DHLink Synchronization refers to two-way synchronization meaning that whenever data in the source is updated, data in the target item will be updated as well and vice versa. When you synchronize data with bidirectional DHLink, DataHub will establish consistency in data hierarchy in both items.

If two data items have an association, they can be opened from one another.

**Synchronized**

Synchronized refers to the status of an item that does not have any pending changes.

**Schema Map**

A Schema Map refers to the mapping of attributes between the source and target types. The source or target types can be identical or different. Apart from mapping, you can also use schema maps to copy items from different item types and update them for attribute synchronization.

Table 23 below is an example of attribute mapping between the MagicDraw® and DOORS formal module.

**Table 23 -- Example of Schema Map**

<table>
<thead>
<tr>
<th>MagicDraw® SysML Requirements</th>
<th>Functional Requirements Module</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Object Heading</td>
</tr>
<tr>
<td>Id</td>
<td>Object Identifier</td>
</tr>
<tr>
<td>Text</td>
<td>Object Text</td>
</tr>
</tbody>
</table>

**Mapping Mode**

DataHub has two types of mapping, which are Individual Type Mapping and Group Type Mapping. The Individual Type Mapping shows the same nodes structure as the dragged nodes and you need to
map every source node to a target node. The Group Type Mapping groups nodes according to their types. It allows you to map a source type to a target type.

**Status**

Status refers to the status of an association item. The status of an item will vary depending on the association type (Sync DHLink). If the association type is a Sync DHLink, the item status will be *Synchronized*, *PendingUpdate*, *PendingDelete*, *Excluded*, or *Orphan*.

**Unidirectional**

This a one way synchronization either from source to target or target to source. Unidirectional sync will change only one side of source and target.