All material contained herein is considered proprietary information owned by No Magic, Inc. and is not to be shared, copied, or reproduced by any means. All information copyright 2007-2010 by No Magic, Inc.
CONTENTS

1 MAGICRQ PLUGIN  6
1.1 Getting Started  6
   1.1.1 Installation  6
      1.1.1.1 Windows 6
1.2 Introduction to MagicRQ Plugin Features  11
   1.2.1 Create Association  11
   1.2.2 Create New Requirement  11
   1.2.3 Create New Element  11
   1.2.4 Create Diagram from Requirement Type  11
   1.2.5 Data Synchronization  11
   1.2.6 View and Report  12
   1.2.7 Open Associated Element/Requirement  13
   1.2.8 Hot Keys  13
1.3 MagicRQ Settings and Options  15
   1.3.1 Customizing Features  15
   1.3.2 MagicRQ Options  15
      1.3.2.1 General Options 17
      1.3.2.2 Notification Options 19
      1.3.2.3 Data Synchronization Options 20
      1.3.2.4 Attributes Options 22
      1.3.2.5 Element Attributes 23
      1.3.2.6 Requirement Attributes 24
   1.3.3 Hot Key Options  25
1.4 Working with MagicRQ Layout  27
   1.4.1 MagicRQ Explorer  30
   1.4.2 MagicRQ Requirements Tree  30
      1.4.2.1 Requirement Information Format 30
   1.4.3 Requirement Properties  31
   1.4.4 Creating Associations  32
   1.4.5 Creating Elements  35
   1.4.6 Creating Requirements  36
1.5 Working with MagicRQ Requirement  38
   1.5.1 Managing Requirements from MagicRQ Requirement Pane  38
   1.5.2 Updating Requirements  38
   1.5.3 Deleting Requirements  40
   1.5.4 Opening Requirements  41
CONTENTS

1.5.5 Opening Elements 41
1.6 Glossary 42

2 MAGICRQ IN RM TOOL 43
2.1 Telelogic DOORS with MagicDraw 43
   2.1.1 MagicRQ Menu 44
   2.1.2 MagicRQ Shortcut Menu 45
   2.1.3 MagicRQ Hot Keys 46
   2.1.4 Creating Associations 46
   2.1.5 Creating Elements 48
   2.1.6 Creating New Locations 50
   2.1.7 Modifying Attributes 50
   2.1.8 Creating Diagrams 51
   2.1.9 Synchronizing Data 54
   2.1.10 Opening Associated Elements 54
   2.1.11 Opening the View and Report Window 55
2.2 Rational RequisitePro with MagicDraw 57
   2.2.1 Installing MagicRQ Plugin in RequisitePro 57
   2.2.2 MagicRQ Menu in RequisitePro 58
   2.2.3 Creating Associations 59
   2.2.4 Creating Elements 60
   2.2.5 Creating New Locations 62
   2.2.6 Modifying Attributes 62
   2.2.7 Creating Diagrams 63
   2.2.8 Synchronizing Data 65
   2.2.9 Opening Associated Elements 66
   2.2.10 Opening the View and Report Window 66

3 MAGICRQ IN MAGICDRAW 67
3.1 MagicRQ Plugin Menu 67
3.2 Integration with Telelogic DOORS 68
   3.2.1 Installing MagicRQ Plugin in DOORS 68
   3.2.2 Connecting to DOORS 68
      3.2.2.1 DOORS Project Browser 69
      3.2.2.2 Quick Reference 70
## CONTENTS

3.2.3 Creating Associations   70  
3.2.4 Creating DOORS Requirements   73  
    3.2.4.1 Creating New Formal Modules 74  
    3.2.4.2 Modifying Attributes 75  
3.2.5 Opening Associated Requirements   76  
3.2.6 Synchronizing Data   77  
    3.2.6.1 Data Synchronization Summary 77  
3.2.7 Opening the View and Report Window   78  
    3.2.7.1 Shortcut Menu 80  
    3.2.7.2 View and Report Window Commands 80  
3.3 Integration with Rational RequisitePro   82  
    3.3.1 Connecting to RequisitePro 82  
    3.3.1.1 Quick Reference 83  
    3.3.2 Creating Associations 83  
    3.3.3 Creating RequisitePro Requirements 86  
    3.3.3.1 Creating New Locations 87  
    3.3.3.2 Modifying Attributes 88  
3.3.4 Opening Associated Requirements 89  
3.3.5 Synchronizing Data   90  
3.3.6 Opening the View and Report Window   90  
3.3.7 Migration   90
1 MAGICRQ PLUGIN

1.1 Getting Started

MagicRQ Plugin 16.6 is the MagicDraw integration with the following requirement management tools:

1. IBM/Rational® RequisitePro®
2. Telelogic DOORS®

1.1.1 Installation

1.1.1.1 Windows

To install from the MagicDraw server:

1. Open MagicDraw.
2. On the main menu, click Help > Resource/Plugin Manager. The Resource/Plugin Manager dialog will open (Figure 1).
3. Click the **Check for Updates** button. A dialog will open prompting you to make a selection (Figure 2).
4. Click the **HTTP Proxy Settings** button (optional). Select the **Use HTTP proxy server** check box and specify a connection to start the update process. Click **OK** (Figure 3).

![HTTP Proxy Server Connection Dialog](image)

**Figure 3 -- HTTP Proxy Server Connection Dialog**

5. In the **Resource/Plugin Manager** dialog, select the **MagicRQ 16.6** check box and click **Download / Install** (Figure 4).
Getting Started

To install from the file:

2. Open MagicDraw.
3. On the main menu, click Help > Resource/Plugin Manager.
4. Click Import.
5. Select the MagicRQ_Plugin_16.6.zip file location in the resource browser dialog.
6. Click Open.
7. Restart MagicDraw after the installation has been completed.

Figure 4 -- Selecting MagicRQ 16.6 to Download

6. Restart MagicDraw after the installation has been completed.
Before using MagicRQ Plugin in the RequisitePro or Telelogic Doors application, you need to complete the integration process.

To integrate with Rational RequisitePro:

2. Click Add... > Browse... to search for the md_integrate.mnu file in the <MagicDraw home>\plugins\com.nomagic.magicdraw.magicrq directory.
3. In the Name box, type the plugin name: MagicRQ and click OK.
4. Restart the Rational RequisitePro application to activate MagicRQ Plugin.

To integrate with Telelogic DOORS:

2. Click the General tab and select Telelogic DOORS from the Default Requirement Tool box.
3. Select DOORS Install Location, for example, C:\Program Files\Telelogic\DOORS_ET).
4. Select a DOORS version installed on your computer from the Version box. Version 8.0 is selected by default.
5. Click Apply to apply the changes and click OK.
6. Restart your computer to activate MagicRQ Plugin.

**NOTE**

- MagicRQ Plugin supports Windows only.
- A license key must be inserted every time MagicRQ is installed.
- To work with a 64-bit platform, the system requires MS Visual C++ 64-bit Library (see MagicRQ_Readme.html for more information).
- HTTP Proxy Server Connection is needed if you are using a proxy server in the internal network.
1.2 Introduction to MagicRQ Plugin Features

MagicRQ 16.6 fixed issues and supports all features from the previous version (16.5), and integrates with MagicDraw version 16.6 and greater.

1.2.1 Create Association

Use Create Association to create an association between an element and a requirement easily by using MagicRQ Layout features.

1.2.2 Create New Requirement

Use Create New Requirement to create a new requirement from an element by dragging the element to a root node (of the requirement type) or module. You can also customize attributes/tags to be copied from an element to a requirement by using default attribute options.

1.2.3 Create New Element

Use Create New Element to create a new UML/SysML/DoDAF element by using the dialog style and drag-and-drop feature. The customized attributes options can be applied to different element types.

1.2.4 Create Diagram from Requirement Type

You can export the whole requirement type to a Use Case or SysML Requirement diagram. All the requirements will be exported as Use Cases or SysML Requirement elements by using the default custom attributes option. When you export requirements to a SysML Requirement diagram, the parent and child relationship of the requirements will be copied to the SysML Requirement diagram.

1.2.5 Data Synchronization

MagicRQ activates Data Sync automatically when you save a project. You can also activate Data Sync manually from the menu. The detailed process of Data Sync is as follows:

- Synchronizing within an active MagicDraw project and a default RM tool. The default RM tool is the one you selected from the Options dialog.
• Comparing the last saved elements or requirements with the current ones.
• If there are changes found, the association status will change to **Suspect** or will overwrite the changes found in one element/requirement with those found in another element/requirement according to the default **Impact Behavior** setting. If both sides are changed, the owner will overwrite the copy.
• If an associated element or requirement is deleted, the association status will change to **Orphan** or will delete the associated element/requirement according to the default **Delete** option.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>• The Data Synchronization overwrite and delete options can only be applied to Sync Association.</td>
</tr>
<tr>
<td>• An element allows only one Sync Association with a requirement from the same requirement project.</td>
</tr>
<tr>
<td>• A requirement allows more than one Sync Association with a different element type or element from a different location.</td>
</tr>
<tr>
<td>• When you change from <strong>No Sync</strong> to <strong>Sync</strong>, the owner will overwrite the copy and change the status to <strong>Sync</strong>. But <strong>Data Synchronization</strong> will not perform until the <strong>Data Synchronization</strong> process is called from the menu or <strong>Auto Sync</strong> is activated.</td>
</tr>
</tbody>
</table>

### 1.2.6 View and Report

You can filter associations by using the following filters:

1. **Elements/requirements**
   - **Associated**: a list of associations between elements and requirements.
   - **Non Associated**: a list of elements or requirements without associations.

2. **Element Type**
   - All element types from the previously created associations.

3. **Requirement Location**
   - All requirement locations from the previously created associations.

4. **Association Status**
   - **Active**: the associated element or requirement contains no changes.
   - **Suspect**: the associated element or requirement contains changes.
   - **Orphan**: the associated element or requirement has been deleted.
• **Deleted:** the association has been deleted.

You can generate a report by using the current filter setting from the **View and Report** window. The **View and Report** window supports commands to view suspect, delete, clear status (accept changes), and overwrite.

You can compare information from suspect associations and decide to overwrite from a requirement to element or an element to requirement. The **View Suspect** and **Overwrite** commands are only available for Sync Association.

### 1.2.7 Open Associated Element/Requirement

You can open associated elements or requirements easily by using a hyperlink or MagicRQ Layout.

### 1.2.8 Hot Keys

MagicRQ supports hot keys to:

#### 1.2.8.1 In MagicDraw

- Connect to a requirement tool
- Create associations
- Create requirements
- Open associated requirements
- Open the View and Report window
- Perform data synchronization
- Open MagicRQ Layout

#### 1.2.8.2 In DOORS

- Create associations
- Create elements
- Create diagrams
- Open associated elements
- Open the View and Report window
- Perform data synchronization
| NOTE                      | RequisitePro does not currently support hot keys. |
1.3 MagicRQ Settings and Options

1.3.1 Customizing Features

You can customize MagicRQ features by modifying the default settings through the Options dialog. There are five default options: General, Notification, Data Synchronization, Customize Attributes, and Hot Key.

1.3.2 MagicRQ Options

The Options dialog consists of all MagicRQ functions. The five default option tabs in the MagicRQ Options dialog are (Figure 5):

1.3.2.1 General Options tab

1.3.2.2 Notification Options tab

1.3.2.3 Data Synchronization Options tab

1.3.2.4 Customize Attributes Options tab

1.3.2.5 Hot Key Options tab
You can change the default settings in each option tab such as the name conversion setting, default requirement tool (RequisitePro / Telelogic DOORS), notification dialogs for successful operations, suspect or overwrite command for data synchronization, and the default customize attributes for exporting data between a MagicDraw element and a DOORS requirement object.

To change the default settings in the Options dialog:

1. Click MagicRQ > Options. The Options dialog will open (Figure 6).
2. Modify the settings according to your needs.

1.3.2.1 General Options

![Options Dialog](Image)

The **General** tab contains information about (i) Name Conversion Setting, (ii) a default requirement tool, and (iii) the DOORS location. You can specify which Name Conversion Setting options you want when creating an association between an element and a requirement. If the default requirement tool is Telelogic DOORS, you need to define the default DOORS installation location.
A detailed description of each part is as follows:

(i) Name Conversion Setting

- Element to Requirement
  - **Apply element name to requirement name.** When you create an association from an element, the element name will overwrite the requirement name.
  - **Do not apply.** This option is selected by default; name conversion will not be applied when you create an association from an element to a requirement.

- Requirement to Element
  - **Apply requirement name to element name.** When you create an association from a requirement, the requirement name will overwrite the element name.
  - **Apply requirement text to element name.** When you create an association from a requirement, requirement text will overwrite the element name.
  - **Do not apply.** This option is selected by default; name conversion will not be applied when you create an association from a requirement.

(ii) Requirement Tool

The requirement tool you selected will be used for all MagicRQ operations. Currently there are two requirement tools that MagicRQ can integrate with: Rational RequisitePro and Telelogic DOORS.

| NOTE | Rational RequisitePro is selected by default. |

(iii) DOORS Location

It is necessary that you specify the install location and version of DOORS in order to integrate MagicRQ with Telelogic DOORS. If you have not defined the location in this tab, the DOORS integration functions will not work and you cannot connect to DOORS from MagicDraw nor use MagicRQ in DOORS. Once the location is defined, MagicRQ Plugin and its menu will be installed in DOORS. You need to restart your computer for the changes to take effect.
1.3.2.2 Notification Options

You can select a notification dialog for each successful operation by selecting the Dialog Notification check boxes in the Notification tab (Figure 7). All options are selected by default.
1.3.2.3 Data Synchronization Options

You can select which Data Synchronization options you need from the **Data Synchronization** tab. The tab consists of three parts: (i) Impact Behavior, (ii) Deletion, and (iii) Auto Sync.

A detailed description of each part is as follows:

(i) **Impact Behavior**

- **Suspect**: If there are changes found during the sync process, the association status will change to **Suspect** for both Sync and No Sync Association.
• **Overwrite.** If there are changes found during the sync process, the changes in one element or requirement will overwrite the changes in another element or requirement. This **Overwrite** option can be applied only to Sync Association. If there are changes found in both elements or requirements, the owner will overwrite the copy, for example, when an association is created from MD to a requirement tool, the element will overwrite the requirement and vice versa.

(ii) **Deletion**

• **Do not delete requirement/element.** If an associated element or requirement is deleted, the association status will change to **Orphan** for both Sync and No Sync Association.

• **Delete requirement/element.** If an associated element or requirement is deleted, MagicRQ will delete the other associated element or requirement and change the association status to **Deleted.** The **Delete** option applies to Sync Association only.

(iii) **Auto Sync**

• **On.** When Auto Sync is on, MagicRQ will automatically perform data synchronization when you save a MagicDraw project.

• **Off.** When Auto Sync is off, MagicRQ will not perform Auto Sync for MagicDraw and DOORS.

To save a DOORS module:

• On the DOORS module menu, click **File > Save** or press **Ctrl + S** (hot key).
1.3.2.4 Attributes Options

You can select which attributes options you need when creating a new element or requirement in the Attributes tab. The Attributes tab consists of two parts: (1.3.6.1) Element Attributes and (1.3.6.2) Requirement Attributes.

A detailed description of each part is as follows:
1.3.2.5 Element Attributes

This part allows you to select (i) an element type and (ii) attributes when creating an element from a requirement.

(i) Element Type

Element types include UseCase, Interface, Package, Class, Actor, Requirement, and Others (other element types).

(ii) Attributes

Attributes to be copied when creating an element from the selected element type.

- **All.** If you click **All**, all attributes will be copied.
- **Customize.** If you click **Customize**, you can copy requirement short text or requirement text, or both.
  - **Requirement Name:** this option, selected by default, will copy a requirement name/heading as the element name.
  - **Requirement Short Text:** to copy requirement short text to the element (only for DOORS).
  - **Requirement Text:** to copy object text to the element (only for DOORS).

To copy all element attributes:

- Select an element type, and then click **All** to copy all attributes from a requirement to an element.

You can choose not to copy all element attributes when you create a new element or requirement by clicking the **Modify Attribute** button in the **New Element** or **New Diagram** dialog.
1.3.2.6 Requirement Attributes

This part allows you to copy attributes, element name, or element type when creating a requirement from an element.

Attributes

Attributes to be copied when creating a requirement.

- **All.** If you click **All**, all tags from an element will be copied as requirement attributes.
- **Customize.** If you click **Customize**, you can copy an element name or type, or both to a requirement.
  - **Element Name:** this option, selected by default, will copy an element name as the requirement name.
• **Element Type.** An element type will be copied to a requirement attribute.

**NOTE**

• All attributes will be resynchronized during the synchronization process according to your attribute settings.

• If you click **All**, all attributes will be synchronized for both Rational RequisitePro and DOORS.

### 1.3.3 Hot Key Options

![Figure 10 -- Hot Key Options Tab in the MagicRQ Options Dialog](image)

*Figure 10 -- Hot Key Options Tab in the MagicRQ Options Dialog*
By default, no keyboard shortcut (hot key) is defined for MagicRQ functions. You need to use an uppercase letter to create a keyboard shortcut (hot key) and it should not duplicate any other MagicDraw hot keys.

You can define hot keys to:

1. Connect to a requirement tool
2. Create associations
3. Open the View and Report window
4. Create requirements
5. Open associated requirements
6. Synchronize data
7. Open MagicRQ Layout
1.4 Working with MagicRQ Layout

MagicRQ Layout contains MagicRQ Explorer and MagicRQ Requirement pane (Figure 11).

To demonstrate the drag-and-drop feature, later in this section you will find a DOORS project called Sport Utility Vehicle is used as an example.

To open MagicRQ Layout:

To create a connection to a project in another requirement tool:

1. On the MagicDraw menu, click **Window > MagicRQ Layout** (Figure 12). The **Project Connection** dialog will open.

   ![MagicRQ Layout Menu](image)

   **Figure 12 -- MagicRQ Layout Menu**

2. Select a DOORS project that you want to connect (Figure 13).
3. In the **Select Project Name** box, select a project (Figure 14).

4. The requirement tree will be loaded and expanded by default.
1.4.2 MagicRQ Explorer

MagicRQ Explorer lists all items, modules, and requirements of the selected DOORS project and requirements of the selected Rational RequisitePro requirement type.

1.4.3 MagicRQ Requirements Tree

Table 1 -- MagicRQ Requirements Tree Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌳</td>
<td>Root</td>
<td>The root of the tree: a DOORS project or RequisitePro requirement type.</td>
</tr>
<tr>
<td>🌳</td>
<td>Folder</td>
<td>A DOORS items folder.</td>
</tr>
<tr>
<td>🌳</td>
<td>Formal Module</td>
<td>The DOORS Formal Module.</td>
</tr>
<tr>
<td>🌳</td>
<td>Requirement</td>
<td>A requirement without MagicRQ associations.</td>
</tr>
<tr>
<td>🌳</td>
<td>Requirement has association</td>
<td>A requirement with one or more associations and all the associations are active.</td>
</tr>
<tr>
<td>🌳</td>
<td>Requirement has suspect association</td>
<td>A requirement with one or more suspect associations.</td>
</tr>
</tbody>
</table>

1.4.3.1 Requirement Information Format

A requirement is written in the order of [KEY][NAME][TEXT].

For DOORS

- **KEY**: Absolute Number
- **NAME**: Object Number, Object Heading
- **TEXT**: Object Text

For RequisitePro

- **KEY**: Tag
- **NAME**: Name
- **TEXT**: Text
1.4.4 Requirement Properties

The Requirement Properties section in the MagicRQ Requirement pane consists of Properties and Attributes tabs. The Properties tab shows the requirement name, short text, and description. The Attributes tab shows all attribute names, types, and values.

The MagicRQ Association section in the MagicRQ Requirement pane shows the incoming and outgoing associations. Incoming and outgoing associations will be listed in the order of [Association Type][Status][Element Type][Owner][Name].

- **Incoming Association**: an association that is created from an element to a requirement. The element will overwrite the requirement if both sides have Sync Association changes.
- **Outgoing Association**: an association that is created from a requirement to an element. The requirement will overwrite the element if both sides have Sync Association changes.
- **Association Type**: There are two association types: (i) Sync (both element and requirement must always be the same) and (ii) No Sync (both associated element and requirement are just associated).
- **Status**: an association status, such as Active, Suspect, Orphan, or Deleted.
- **Element Type**: an element type, such as Requirement, Use Case, and Class.
- **Owner**: the parent name of an element.
- **Name**: an element name.
1.4.5 Creating Associations

To create an association from the Containment tree to MagicRQ Explorer:

1. Select an element from the Containment tree.
2. Drag the element to a requirement in MagicRQ Explorer to create an association between them (Figure 16).
3. The association will be created and (the association icon) will appear in front of the requirement.

Figure 16 -- Dragging an Element from the Containment Tree to a Requirement in MagicRQ Explorer
To create an association from MagicRQ Explorer to the Containment tree:

1. Select a requirement from MagicRQ Explorer.
2. Drag the requirement to an element in the Containment tree to create an association between them (Figure 17).
3. The association will be created and the association icon will appear in front of the requirement.
To create an association from MagicRQ Explorer to an active diagram:

1. Select a requirement from MagicRQ Explorer.
2. Drag the requirement to the element in the active diagram to create an association between them (Figure 18).
3. The association will be created and the association icon will appear in front of the requirement.

Figure 18 -- Dragging a Requirement from MagicRQ Explorer to an Element in the Active Diagram
1.4.6 Creating Elements

To create an element:

1. Select a requirement from MagicRQ Explorer.
2. Right-click and select an element type to be created (Figure 19).
3. Drag the requirement to an empty space in the active diagram. A new use case and association will be created for the requirement you selected (Figure 20).
1.4.7 Creating Requirements

To create a new requirement:

1. Select an element from the Containment tree.
2. Drag the element to a module with icon (DOORS) or a root node of the requirement type (RequisitePro) to create a new requirement for (Figure 21).
3. A new requirement and association will be created for the element you selected. The newly created requirement will appear in the Containment tree (Figure 22).

Figure 22 -- A New Requirement in the Requirement Tree
1.5 Working with MagicRQ Requirement

1.5.1 Managing Requirements from MagicRQ Requirement Pane

The MagicRQ Requirement pane has two different sections: (i) Requirement Properties and (ii) MagicRQ Association.

(i) Requirement Properties

The Requirement Properties section allows you to manage requirements inside the MagicDraw application. You can update, delete, or open a requirement in a requirement management tool. When updating or deleting a requirement from the Requirement Properties section, the synchronization process will perform according to the default Data Synchronization settings.

(ii) MagicRQ Association

The MagicRQ Association section shows incoming and outgoing associations. Associations created from the Containment tree to MagicRQ Explorer are called incoming associations. Associations created from MagicRQ Explorer to the Containment tree or element in an active diagram are called outgoing associations. By default, creating a requirement will create an incoming association and creating an element will create an outgoing association. These association rules are applied to the overwrite process when the owner overwrites the copy. The owner of an incoming association is an element; therefore, the element will overwrite the requirement. The owner of an outgoing association is a requirement.

You can open a shortcut menu inside the Incoming and Outgoing association lists by right-clicking an association. All View and Report functions are available in the association shortcut menu. You can easily manage associations using the functions from the MagicRQ Requirement pane.

1.5.2 Updating Requirements

To auto synchronize elements and requirements from the MagicRQ Requirement pane:

- Click the Overwrite button in the Data Synchronization tab in the MagicRQ Options dialog.
To manually synchronize elements and requirements from the MagicRQ Requirement pane:

- Click the **Suspect** button in the Data Synchronization tab in the MagicRQ Options dialog.

To manually update a requirement:

1. Right-click a requirement and select **Show Properties**. The MagicRQ Requirement pane will open (Figure 23).

2. For example, type: **User shall be able to plan the journey** in the Description box.

3. If the requirement has no Sync Association, you can create a Sync Association by right-clicking the requirement in the Incoming Association and select **Sync**.

4. Click **Save**. If the requirement has one or more Sync Associations and the Impact Behavior setting is **Suspect**. Click **OK** to confirm and synchronize with the associated element.

**NOTE**

After clicking **Save**, if the Impact Behavior setting is **Overwrite**, a message will open: **The requirement data will overwrite to all Sync Associated elements. Select Cancel to mark as Suspect.**
5. **Object Text** in the SysML Requirement tag will also change to *User shall be able to plan the journey* (Figure 24).

![Figure 24 -- A Synchronized Element](image)

### 1.5.3 Deleting Requirements

To synchronize elements and requirements from the **MagicRQ Requirement** pane, click the **Delete** button in the **Data Synchronization** tab in the **MagicRQ Options** dialog.

To delete a requirement:

1. Right-click a requirement you want to delete and select **Show Properties**. The **MagicRQ Requirement** pane will open.
2. Click the **Delete** button (Figure 25). If the requirement has one or more Sync Association and the **Delete** setting is **Delete requirement/element**, a message will open: *The associated element will delete. Select Cancel to mark as Orphan.*

![Figure 25 -- Confirming to Delete an Associated Element](image)

3. Click **OK** to delete the associated element.

### 1.5.4 Opening Requirements

To open a requirement in the requirement tool through the MagicRQ Requirement pane:

1. Right-click a requirement you want to open and select **Show Properties**. The **MagicRQ Requirement** pane will open.
2. Click **Open** and the requirement module will open and highlight the requirement you selected.

### 1.5.5 Opening Elements

To open an associated element in the Containment tree through the MagicRQ Requirement pane:

1. Select a requirement with ![Read-Only](image) in front of it.
2. Double-click the association in the Incoming or Outgoing association list. The associated element will be highlighted in the Containment tree.
1.6 Glossary

Active
A status of an association when the association is synchronized and active.

Deleted
A status of an association when the association is removed by performing a data synchronization process or upon the user’s request.

Suspect
A status of an association when the associated element or requirement has been changed.

Orphan
A status of an association when the associated element or requirement has been deleted.

Data Sync
The data synchronization process.

MD
MagicDraw.

No Sync Association
The element and requirement are associated, but are not identical. The automatic overwrite and delete options cannot be applied to this association. Any changes found on either side will have the association status changed to “Suspect”.

Sync Association
The element and requirement are associated and identical. The automatic overwrite and delete options can be applied to this association.

RM Tool
A requirement management tool, for example, Rational RequisitePro or Telelogic DOORS
2.1 Telelogic DOORS with MagicDraw

After specifying the DOORS install location in the General tab in the MagicRQ Options dialog, you can use the MagicRQ menu in DOORS.

You can access MagicRQ functions from: (2.1.1) MagicRQ main menu, (2.1.2) MagicRQ shortcut menu, or (2.1.3) hot keys

If Auto Data Synchronization is on, MagicRQ will synchronize data when you save a project by pressing the hot key or click Save on the File menu. [Refer to "Data Synchronization Options"]
2.1.1 MagicRQ Menu

To access MagicRQ functions in Telelogic DOORS:

- On the MagicRQ menu in the DOORS Formal Module window, select the function you want to perform (Figure 26).

![MagicRQ Menu in DOORS](image-url)
2.1.2 MagicRQ Shortcut Menu

Figure 27 -- MagicRQ Shortcut Menu in DOORS

To open the MagicRQ shortcut menu in Telelogic DOORS:

1. Right-click an object in the Formal Module window and select the MagicRQ function that you want to perform (Figure 27).
2.1.3 MagicRQ Hot Keys

The following MagicRQ hot keys or keyboard shortcuts are available in the DOORS Formal Module window.

Table 2 -- MagicRQ Hot Keys

<table>
<thead>
<tr>
<th>Function</th>
<th>Hot keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Association</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>New Element</td>
<td>Ctrl + M</td>
</tr>
<tr>
<td>New Diagram</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Open Associated Element</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Data Synchronization</td>
<td>Ctrl + Y</td>
</tr>
<tr>
<td>View and Report</td>
<td>Ctrl + R</td>
</tr>
</tbody>
</table>

2.1.4 Creating Associations

You can create associations from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

(i) To create an association from the main menu:

2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select an element type and the location of the element you want to associate.
4. Click Associate to create an association.

(ii) To create an association from the shortcut menu:

1. Right-click an object and select MagicRQ > Create Association. The Associate UML Element dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select an element type and the location of the element you want to associate.
4. Click Associate to create an association.
(iii) To create an association by using the keyboard shortcut (hot key):

1. Press **Ctrl + A**.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select an element type and the location of the element you want to associate.
4. Click **Associate** to create an association (Figure 28).

---

**Figure 28 -- MagicRQ in DOORS - Create Association Dialog**
The association will be created from the selected requirement and element with the default sync option. Any changes found in the requirement or element will be marked as Suspect and you can clear or view the status from the View and Report window. The default overwrite and delete options cannot be applied to this association. If the requirement or element is deleted, the association status will change to Orphan.

### 2.1.5 Creating Elements

You can create elements from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

**(i) To create an element from the main menu:**

2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select **Profile** > **Element Type** and enter an element name. The requirement heading will open by default. If you want to change the name, a dialog box will prompt you to confirm updating the requirement heading with the new element name or use the requirement heading as the element name.
4. Click **OK**.

**(ii) To create an element from the shortcut menu:**

1. Right-click an object and select **MagicRQ** > **Create Element**. The New UML Element dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select **Profile** > **Element Type** and enter an element name. The requirement heading will open by default. If you want to change the name, a dialog box will prompt you to update the requirement heading with the new element name or use the requirement heading as the element name.
4. Click **OK**.

**(iii) To create an element by using the keyboard shortcut (hot key):**

1. Press **Ctrl + M** and select **MagicRQ** > **Create Element**. The New UML Element dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.

3. Select Profile > Element Type and enter an element name (Figure 29). The requirement heading will open by default. If you want to change the name, a dialog box will prompt you to confirm updating the requirement heading with the new element name or use the requirement heading as the element name.

4. Click OK.
You can create a new package (location) for the new element you are creating. You may also modify the attributes that you want to copy from the DOORS requirement to the MagicDraw element. If you do not modify any attribute, the default attribute options will be used when creating a new element.

Once the new element has been created, a new MagicRQ association will also be created with the default sync option. MagicRQ will use the default overwrite and delete options if there are changes found in the requirement or element.

### 2.1.6 Creating New Locations

**Figure 30 -- MagicRQ in DOORS - New Location Dialog**

To create a new location:

1. Select the parent folder or location to create a new location.
2. Click the **New Location** button. The **New Location** dialog will open (Figure 30).
3. Select a **Location Type**. **Model** is selected by default.
4. Type a **Location Name**.
5. Click **OK**. A new location will be created and loaded to the location tree in the **New UML Element** dialog.

### 2.1.7 Modifying Attributes

To modify an attribute:

1. Select a requirement.
2. On the MagicRQ menu, click **New Element**. The **New UML Element** dialog will open.
3. Click **Modify Attribute** to customize the attributes that will be copied from the require-
ment to an element. All attributes from the selected requirement will open in the **Attri-
butes** dialog.
4. Select the attribute that you want to copy to the MagicDraw element.
5. Click **Save** to save the custom attributes settings.

By default, the custom attribute settings from the MagicRQ **Options** dialog will be used to create a
new element [refer to "Attributes Options"]. If you modify the attribute by using the **Attributes** dialog,
only the selected attributes will be copied to the MagicDraw element and used by data sync.

### 2.1.8 Creating Diagrams

You can create a diagram from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

(i) To create a diagram from the main menu:

1. On the MagicRQ menu in the Formal Module window, click **Create Diagram**. The
**New UML Diagram** dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name
will be shown by default.
3. Select **Requirement Type** and type a **Diagram Name**.
4. Select a **Diagram Type**, such as Use Case Diagram or Requirement Diagram. A
Requirement diagram will be available if you have SysML Plugin installed.
5. Click **New Location > Location** to create a location for the diagram.
6. Click **Modify Attribute** to customize the attributes to be copied from the selected
requirement type to all elements.
7. Click **OK** to create the diagram.

(ii) To create a diagram from the shortcut menu:

1. Right-click an object and select MagicRQ > **Create Diagram**. The **New UML
Diagram** dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will
be shown by default.
3. Select **Requirement Type** and type a **Diagram Name**.
4. Select a **Diagram Type**, such as Use Case Diagram or Requirement Diagram. A
Requirement diagram will be available if you have SysML Plugin installed.
5. Click **New Location > Location** to create a location for the diagram.
6. Click **Modify Attribute** to customize the attributes to be copied from the selected requirement type to all elements.
7. Click **OK** to create the diagram.

(iii) To create a diagram by using the keyboard shortcut (hot key):

1. Press **Ctrl + D**. The **New UML Diagram** dialog will open.
2. Select a MagicDraw project file. If MagicDraw is currently open, the file path name will be shown by default.
3. Select **Requirement Type** and type a **Diagram Name**.
4. Select a **Diagram Type**, such as Use Case Diagram or Requirement Diagram. A Requirement diagram will be available if you have SysML Plugin installed.
5. Click **New Location > Location** to create a location for the diagram.
6. Click **Modify Attribute** to customize the attributes to be copied from the selected requirement type to all elements.
7. Click **OK** to create the diagram.
Then the diagram will start to create all the elements for the selected requirement type. This process may take several minutes depending on the number of requirements included in the selected requirement type. The progress indicator will show the status of the diagram creation.

Once the process has been completed, a MagicRQ association will be created for each element and requirement with the default Sync options. The process of creating diagrams is the same as that of elements.
2.1.9 Synchronizing Data

You can synchronize data from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

(i) To synchronize data from the main menu:

- On the MagicRQ menu in the Formal Module window, click Data Synchronize to start synchronizing data.

(ii) To synchronize data from the shortcut menu:

- Right-click an object, select MagicRQ > Data Synchronize.

(iii) To synchronize data by pressing the hot key (keyboard shortcut):

1. Press Ctrl + Y. The Data Synchronization process will start.

For more details on Data Synchronization, refer to "Data Synchronization".

2.1.10 Opening Associated Elements

You can open an associated element from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

(i) To open an associated element from the main menu:

1. On the MagicRQ menu in the Formal Module window, click Open Associated Element.
2. If the selected object has more than one MagicRQ association, the **Open Associated UML element** dialog will open. Select an element to be opened. If the requirement does not have any MagicRQ associations, the **No Association** message will open.

(ii) To an associated element from the shortcut menu:

1. Right-click an object and select **MagicRQ > Open Associated Element**.
2. If the selected object has more than one MagicRQ association, the **Open Associated UML element** dialog will open. Select an element to be opened. If the requirement does not have any MagicRQ associations, the **No Association** message will open.

(iii) To an associated element by using the keyboard shortcut (hot key):

1. Press **Ctrl + O**.
2. If the selected object has more than one MagicRQ association, the **Open Associated UML element** dialog will open. Select an element to be opened. If the requirement does not have any MagicRQ associations, the **No Association** message will open.

### 2.1.11 Opening the View and Report Window

You can open the View and Report window from the (i) main menu, (ii) shortcut menu, or (iii) hot key.

(i) To open the View and Report window from the main menu:

1. On the **MagicRQ** menu in the Formal Module window, click **View and Report**.
2. If the current DOORS project has MagicRQ associations, the **View and Report** window will open.

(ii) To open the View and Report window from the shortcut menu:

1. Right-click an object and select **MagicRQ > View and Report**.
2. If the current DOORS project has MagicRQ associations, the **View and Report** window will open.

(iii) To open the View and Report window by using the keyboard shortcut (hot key):

1. Press **Ctrl + R**.
2. If the current DOORS project has MagicRQ associations, the View and Report window will open.

For more details on the View and Report window, refer to "Opening the View and Report Window".
2.2 Rational RequisitePro with MagicDraw

2.2.1 Installing MagicRQ Plugin in RequisitePro

You can use the MagicRQ menu to integrate RequisitePro and MagicDraw.

To install MagicRQ Plugin in Requisite Pro:

1. On the Tools menu in RequisitePro, click Add-ins…. The Add-ins dialog will open.
2. Click Add, the New Adds-in dialog will appear.
3. Type: MagicRQ16.6.
4. Click Browse… to search for the md_integrate.mnu file in the MagicDraw installation path (plugins\com.nomagic.magicdraw.magicrq).
5. Select the Active check box.
6. Click OK to enable the MagicRQ menu in RequisitePro.
2.2.2 MagicRQ Menu in RequisitePro

![MagicRQ Menu in RequisitePro](image)

To better enjoy the learning experience, please review this short document first.
To access MagicRQ functions from the MagicRQ menu in RequisitePro:

1. On the Requirement menu in RequisitePro, click MagicRQ.
2. Select the function you want to perform.

### 2.2.3 Creating Associations

To create an association:

1. Select a requirement.
2. On the Requirement menu, click MagicRQ > Create Association (Figure 32). The Associate UML Element window will open (Figure 33).

![Figure 33 -- Creating a New Association in the Associate UML Element Window](image-url)
3. Select a MagicDraw Project File. If MagicDraw is already open, the current MagicDraw project path will be shown by default (Figure 33).
4. Select an Element Type. All element types are selected by default.
5. Select the Location of the element that you want to associate.
6. Click Associate to create an association. A dialog will open to inform you that the association has been created successfully (to enable this dialog, select the Show successful association check box in the Notification tab).

The association will be created from the selected requirement and element with default sync options. MagicRQ marks any changes found from the requirement or element as Suspect and you can clear or view the status from the View and Report window. The default overwrite and delete options cannot be applied to this association. If the requirement or element is deleted, the association status will change to Orphan.

### 2.2.4 Creating Elements

To create an element:

1. Select a requirement.
3. Select a **MagicDraw Project File**. If MagicDraw is already open, the current MagicDraw project path will be shown by default (Figure 34).

4. Select a **Profile**. Available profiles from the current MagicDraw project will be listed.

5. Select an **Element Type**. Available element types for the selected profile will be listed.

6. Enter an **Element Name**. A requirement heading will appear by default. If you want to assign a different name, a dialog box will appear to confirm updating the requirement.
heading as the new element name or using the requirement heading as the element name.

7. Click **OK** to create a new element.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>● You can create a new package (location) for the new element you are creating. You can also modify the attributes that you want to copy from the RequisitePro requirement to the MagicDraw element in the <strong>New UML Element</strong> window. If you do not modify any attribute, the default attribute options will be used when creating a new element.</td>
</tr>
<tr>
<td>● Once the new element has been created, a new MagicRQ association will be created with the default sync options. MagicRQ will use the default overwrite and delete options when it finds any changes in the requirement or element.</td>
</tr>
</tbody>
</table>

### 2.2.5 Creating New Locations

To create a new location:

1. Open the **New UML Element** window and select a parent folder or location to create a new location.
2. Click **New Location**. The **New Location** dialog will appear.
3. Select a Location Type. **Module** is selected by default.
4. Enter the **Location Name**.
5. Click **OK**. The new location will be created and loaded to the location tree in the **New UML Element** window. You can create an element under the new location.

### 2.2.6 Modifying Attributes

To modify an attribute:

1. In the **New UML Element** window, click the **Modify Attribute** button to customize the attributes to be copied from a requirement to an element from the **New UML Element** window.
2. All attributes from the RequisitePro requirement will be listed in the **Attributes** dialog.
3. Select the attributes that you want to copy to the MagicDraw element.
4. Click **Save** to save the custom attribute settings.
By default, the custom attribute settings will be used to create a new element. If you modify the attribute by using the Attributes dialog, only the selected attributes will be copied to the MagicDraw element and used by data sync.

### 2.2.7  Creating Diagrams

To create a new diagram:

2. Select a **MagicDraw Project File**. If MagicDraw is already open, the current MagicDraw project path will be shown by default (Figure 35).

3. Select a **Requirement Type**. For DOORS, the open module paths will be listed. For RequisitePro, the requirement types will be listed.

4. Enter a **Diagram Name**.

5. Select a **Diagram Type**, such as **Use Case Diagram** or **Requirement Diagram**. A Requirement diagram will be available if you have SysML Plugin installed.
6. Click **New Location** to create a new location for the diagram.
7. Select the **Location** for the new diagram.
8. Click **Modify Attribute** to customize the attributes to be copied from the selected requirement type to all elements.
9. Click **OK** to create the diagram.

Then the diagram will start creating all the elements for the selected requirement type. This process may take several minutes depending on the number of requirements included in the selected requirement type. The progress indicator will show the status of the diagram creation.

Once the process has been completed, a MagicRQ association will be created for each element and requirement with the default sync options. The process of creating diagrams is the same as that of elements.

| NOTE | • If there is a conflict when creating an element, MagicRQ will create No Sync Association with a blank element name.  
| | • If the validation rules fail to validate a specific element, MagicRQ will create No Sync Association.  
| | • The parent and child relationship of the requirements will be copied as a containment relationship in the SysML Requirement diagram. |

### 2.2.8 Synchronizing Data

To synchronize data:

1. On the **Requirement** menu, click **MagicRQ > Data Synchronize**.

For more details on Data Synchronization, refer to "Data Synchronization".
2.2.9 Opening Associated Elements

To open an associated element:

1. On the Requirement menu, click MagicRQ > Open Associated Element. If the selected object has more than one MagicRQ association, the Open Associated UML Element window will open.
2. Select the element you want to open. If the requirement does not have any MagicRQ associations, the No Association message will appear.

2.2.10 Opening the View and Report Window

To open the View and Report window:


For more details on the View and Report window, refer to "Opening the View and Report Window".
3 MAGICRQ IN MAGICDRAW

MagicRQ Plugin is a plugin for MagicDraw® application. MagicRQ menu and layout are available for all MagicRQ functions, such as, for example, creating new elements, diagrams, and requirements, and for creating and managing associations.

MagicRQ supports Teamwork projects and Eclipse integration.

- **Teamwork Projects**
  MagicRQ Plugin in MagicDraw is available for both Local and Teamwork projects. However, only the Locked For Edit Teamwork Project elements will be allowed to perform MagicRQ functions.
- **Eclipse Integration**
  MagicRQ menu is also available for MagicDraw in Eclipse (Eclipse). All MagicRQ functions can thus be performed in Eclipse.

3.1 MagicRQ Plugin Menu

You can access MagicRQ functions from MagicDraw through the (i) MagicRQ main menu, (ii) MagicRQ shortcut menu, or (iii) hot keys.

(i) To access MagicRQ functions from the MagicRQ main menu:

- On the MagicRQ menu in MagicDraw, select the function that you want to perform.

(ii) To access MagicRQ functions from the MagicRQ shortcut menu:

- Right-click an element in the Containment tree and select the function that you want to perform.
(iii) To access MagicRQ functions by using the keyboard shortcut (hot key):

- Press the hot key you defined in the Hot Key tab in the MagicRQ Options dialog.

You need to select only one element in the Containment tree to perform the Create Requirement function. You can select one or more elements to create an association and the association will be created for all the selected elements with one requirement.

The MagicRQ menu name is based on the default requirement tool you selected.

### 3.2 Integration with Telelogic DOORS

#### 3.2.1 Installing MagicRQ Plugin in DOORS

In order to integrate with DOORS, you need to select Telelogic DOORS in the Default Requirement Tool box and specify the Telelogic DOORS install location and version.

#### 3.2.2 Connecting to DOORS

You can create a connection between the current MagicDraw and DOORS projects. All the functions are based on the connection that you created.

| NOTE | Data Sync will only work in the project that is currently connected. |
The DOORS Project Connection dialog (Figure 36) consists of:

- **Source**: the default requirement tool that you selected from the General options tab. To change the default requirement tool, click MagicRQ > Options > General tab.
- **Project File**: the currently connected project path or the last connected project path if shown by default.
- **Connection Status**: the currently connected requirement tool with its status and project path. There is no connection by default.

### 3.2.2.1 DOORS Project Browser

This dialog lists all the project names from the DOORS application.
3.2.2.2 Quick Reference

To connect to a different project:

1. On the MagicRQ menu, click Connect to Requirement Project. The Project Connection dialog will open.
2. Click Browse. The Project Browser will open. Click Browse. The Project Browser will open. Select a project that you want to connect from MagicDraw.
3. Click OK.

To change the current requirement tool:

1. On the MagicRQ menu, click Options > General tab.
2. Change the default requirement tool to a new one.
3. Restart MagicDraw for the change to take effect.

3.2.3 Creating Associations

You can create associations from MagicDraw by using the MagicRQ menu, shortcut menu, or pressing the hot key and select an element from the Containment tree.

MagicDraw creates a new hyperlink for each element that has an association with the requirement tools. If you add a MagicRQ hyperlink to your element, the element hyperlink icon will be attached to the element (Figure 37).
MagicDraw will show the MagicRQ hyperlink icon only for the default requirement tool for the current project, for example, if you have created an association with both RequisitePro and DOORS in the same MagicDraw project, only the DOORS association will show with the MagicRQ icon if the Default Requirement Tool selected is DOORS.

You can create an association with a DOORS requirement by using the DOORS Create Association dialog.
To create an association:

1. Click MagicRQ > DOORS or open the shortcut menu, or press the hot key.
2. Select Create Association, the Create Association dialog will open.
3. Select a Project Name from the Project Name box.
4. Select a requirement from the Requirement tree. The requirement tree lists the following items with different icons. Only a requirement can associate with an element.
   - Folder: 📁
   - Formal Module: 📊
   - Requirement without association: 🔄
   - Requirement with association: 🔄
   - Requirement with association when one or more associations are suspect: 🔄
5. Select the Sync check box to synchronize the association.
6. Click OK to create the association.
3.2.4 Creating DOORS Requirements

To create a requirement without attributes under an existing module:

1. Select an element in the Containment tree.
2. Click MagicRQ > DOORS or open the shortcut menu, or press the hot key.
3. Select Create Requirement. The New Requirement Properties dialog will open (Figure 39).

Figure 39 -- DOORS New Requirement Properties Dialog
4. The element name will be written in the requirement **heading**. You can change the heading name by typing a new name in the **Short Text** and **Requirement Text** boxes.
5. Select a **Location** (module or parent requirement) from MagicRQ Explorer.
6. Click **OK**. A new hyperlink will be inserted in the selected element and a new association will be created.

You can create a requirement from the selected element. The element name will be written as the requirement heading. You can either use the default name or change to a new heading. If you change the heading, a dialog box will appear to confirm to overwrite the current element name with the new name or use the current element name for the requirement heading.

### 3.2.4.1 Creating New Formal Modules

![New Formal Module Dialog](image)

**Figure 40 -- DOORS New Formal Module Dialog**

To create a new formal module:

1. Select a parent folder. The **New Location** button will be enabled in the **New Requirement Properties** dialog.
2. Click the **New Location** button. The **New Formal Module** dialog will open (Figure 40).
3. Type the **Name**, **Description**, and **Prefix** for the new module.
4. Click **OK** and the new module will be listed in MagicRQ Explorer.
3.2.4.2 Modifying Attributes

To modify an attribute:

1. Select an element.
2. Click MagicRQ > DOORS or open the shortcut menu, or press the hot key.
3. Select Create Requirement to open the New Requirement Properties dialog. The Modify Attributes button will be enabled if the selected element has additional stereotypes.
4. Click the Modify Attributes button. The Attributes dialog will open with the existing tag values of all stereotypes that have been applied (Figure 41).
5. Select the attributes that you want to copy to the requirement.
6. Click Save and only the selected tags will be copied to the requirement.

Figure 41 -- DOORS Modify Attributes Dialog
3.2.5 Opening Associated Requirements

To open an element with only one association:

2. Either right-click and select Open Associated Requirement (DOORS) or click MagicRQ > DOORS.
3. Select Open Associated Requirement. The associated requirement will be selected in DOORS.

To open an element with more than one association:

2. Either right-click and select Open Associated Requirement (DOORS) or click MagicRQ > DOORS.
3. Select Open Associated Requirement. The Open Associated Requirement dialog will open.
4. Select the element from the Element pane and the associated requirements will open in the Associated Requirement pane.
5. Select the associated requirement and click OK. The requirement will be selected in DOORS.

To open more than one element with at least one association:

2. Either right-click and select Open Associated Requirement (DOORS) or click MagicRQ > DOORS.
3. Select Open Associated Requirement. The Open Associated Requirement dialog will open.
4. Select any element from the Element pane and the associated requirements will open in the Associated Requirement pane.
5. Select the associated requirement and click OK. The requirement will be selected in DOORS.
3.2.6  Synchronizing Data

To synchronize data:

1. On the MagicRQ menu, click DOORS > Data Synchronize. If the currently open MagicDraw project has an association, the synchronization progress indicator will open and show the status.

**NOTE**
- Data Synchronization will work only in the default requirement tool.
- The synchronization status will show the current synchronization associations and the total number of associations required to synchronize.
- The Data Synchronization summary will not open if there are no changes found either in the associated requirement or element.

### 3.2.6.1 Data Synchronization Summary

The Data Synchronization summary will open if any changes are found during the data synchronization process. The summary will show:

- total suspect element/requirement: the total number of associated elements or requirements that have been changed since the last synchronization.
- total overwritten element/requirement: the total number of associated elements or requirements that were overwritten by the changes (if the default setting is Overwrite).
- total orphan element/requirement: the total number of deleted elements or requirements that have associated elements/requirements.
- total deleted element/requirement: the total number of deleted elements or requirements that have associated elements/requirements (if the default setting is set to Delete).
- total deleted hyperlink/association: the total number of deleted elements with MagicRQ hyperlinks.
- total sync association: the total synchronized associations and total number of MagicRQ associations. The associations with a Deleted or Orphan status are ignored in the data synchronization process.
3.2.7 Opening the View and Report Window

To open the View and Report window:

- On the MagicRQ menu, click DOORS > View And Report. The View and Report window will open (Figure 42).
The following filters are available in the View and Report window:

1. Element/Requirement
   - Associated: the associated element/requirement.
   - Non Associated: the element or requirement that does not have any associations.

2. Element Type
   - A list of available element types from the previous associations.

3. Requirement Location
   - A list of requirement locations from the previous associations.

4. Status
   - Active: the association that has no changes.
   - Deleted: the association that has already been deleted.
   - Orphan: the associated element/requirement that has been deleted.
   - Suspect: the association that has changes.

The View and Report window has two tables. If you open the View and Report window from a requirement tool, the upper table will show a list of requirements and the lower table will show a list of associated elements.

If you open the View and Report window from MagicDraw, the upper table will show a list of elements and the lower table will show a list of associated requirements.

Requirement:
   - **Requirement Key**: the Absolute Number of the DOORS objects or the requirement tag of a RequisitePro requirement.
   - **Requirement Name**: the heading of the DOORS object or the name of the RequisitePro requirement.
   - **Requirement Location**: the full module path of the DOORS object or the location of a RequisitePro requirement.

Element:
   - **Element Name**: a MagicDraw element name.
   - **Element Type**: a MagicDraw element type.
Association:

- **Status**: the current association status (Active, Deleted, Orphan, or Suspect).
- **Date Modified**: the association last modification date.
- **Association Type**: Sync or No Sync.

### 3.2.7.1 Shortcut Menu

- **View Suspect**: This menu is available if the selected association status is Suspect and the association type is Sync. If View Suspect is selected, the View Suspect Properties dialog will open. You can perform the overwrite option from a requirement to an element or from an element to a requirement.
- **Open in Containment Tree**: the element will show in the Containment tree.
- **Open in RequisitePro/DOORS**: the requirement will open in RequisitePro/DOORS.
- **Edit**: the hyperlink editor will open for you to modify the MagicRQ association.
- **Sync**: this menu will be available if the selected association type is currently No Sync and the selected associated element or requirement is allowed to have a Sync Association (refer to Sync and No Sync rules). When you select this menu, the association owner will overwrite the other side and change the status to Sync. Sync Association is an association where the element and requirement are identical. The automatic overwrite and delete options can be applied to this association.
- **No Sync**: this menu will be available if the selected association type is currently Sync or the associated element or requirement is not allowed to have a Sync Association. No Sync Association is an association where the element and requirement are associated, but are not identical. The automatic overwrite and delete options cannot be applied to this association. The association status of both the element and requirement will change to Suspect if changes are found on both sides.

### 3.2.7.2 View and Report Window Commands

The following commands apply to all selected associations from the association table. You can select the **Check all** check box to check all the associations from the association table.

- **Clear Status**: to clear all Deleted, Orphan, or Suspect status. By giving this command, the deleted associations will be permanently deleted and they cannot be viewed again. The orphan associations will be deleted and their status will appear as Deleted. The Suspect associations will change to Active without synchronizing the data.
• **Overwrite**: to overwrite all suspect associations. The changes on one side will overwrite the other side. If changes found on both sides, the owner will overwrite the client and the other status will be ignored by the Overwrite option.

• **Delete**: to delete all selected associations. If the association status is deleted, the association will permanently be deleted. If the association status is Suspect, Orphan, or Active, the status will be changed to Deleted. However, if the MagicRQ hyperlink is not active, the association cannot be deleted and the system will show a message to activate the hyperlink or delete the hyperlink manually. When you delete a MagicRQ hyperlink manually, the data synchronization process will automatically delete the association.
3.3 Integration with Rational RequisitePro

3.3.1 Connecting to RequisitePro

You can create a connection between the current MagicDraw and RequisitePro projects. All the functions are based on the connection that you created.

NOTE: Data Sync will work only in the project that is currently connected.

![Figure 43 -- RequisitePro Project Connection Dialog](image)

The RequisitePro Project Connection dialog consists of (Figure 43):

- **Source**: the default requirement tool that you selected from the General options tab. If you want to change the default requirement tool, click MagicRQ > Options > General tab.
• **Project File**: the currently connected project path or the last connected project path if the connection has not yet been created.

• **Connection Status**: the currently connected requirement tool with its status and project path. There is no connection by default.

### 3.3.1.1 Quick Reference

To connect to a different project:

1. Open the **Project Connection** dialog.
2. Click **Browse** and select the project that you want to connect.
3. Click **OK** to connect.

To change the current requirement tool:

1. On the **MagicRQ** menu, click **Options > General** tab.
2. Change the default requirement tool to the one that you want to connect.
3. Restart MagicDraw for the change to take effect.

### 3.3.2 Creating Associations

You can create associations from MagicDraw by either using the MagicRQ menu or the MagicRQ shortcut menu and select an element from the Containment tree.

MagicDraw will create a new hyperlink for each element that has an association with the requirement tools. If you add the MagicRQ hyperlink to your element, the element hyperlink icon will be attached to the element (Figure 44).

![Figure 44 -- Element Hyperlink Icon](image)

MagicDraw will show the MagicRQ hyperlink icon only for the default requirement tool for the current project, for example, if you have created an association with both RequisitePro and DOORS in the
same MagicDraw project, only the RequisitePro association will show the MagicRQ icon if the default requirement tool selected is RequisitePro.

To create an association using the Create Association dialog:

1. Click MagicRQ > RequisitePro or open the shortcut menu, or press the hot key.
2. Select Create Association. The Create Association dialog will open (Figure 45).
3. Select a Project File.
4. Select a requirement type from the Requirement Type box.
5. Select a requirement from the Requirement tree. The Requirement tree lists the following items with different icons. Only a requirement can associate with an element.
   - Requirement Type: 
   - Requirement without association:
   - Requirement with association:
   - Requirement with associations when the status of one or more associations is Suspect:
6. Select the Sync check box to synchronize the association.
7. Click OK to create the association.
3.3.3 Creating RequisitePro Requirements

![RequisitePro Create New Requirement Dialog](image)

Figure 46 -- RequisitePro Create New Requirement Dialog
To create a requirement without attributes under an existing module:

1. Select an element in the Containment tree.
2. Click MagicRQ > RequisitePro or open the shortcut menu, or press the hot key.
3. Select Create Requirement. The New Requirement Properties dialog will open (Figure 46).
4. The element name will be written as the requirement name. You can change the requirement name.
5. Fill in the Requirement Text box.
6. Select a parent package from the location.
7. Click OK. The new hyperlink will be inserted to the selected element and a new association will be created.

You can create a requirement from the selected element. The element name will be written as the requirement heading. You can either use the current name or change to a new one. If you change the heading, a dialog box will appear prompting you to overwrite the current element name with the new name or use the current element name for the requirement heading.

### 3.3.3.1 Creating New Locations

![New Package](image)

*Figure 47 -- RequisitePro Create New Location Dialog*
To create a new location:

1. Select a parent folder. The **New Location** button will be enabled in the **New Requirement Properties** dialog.
2. Click the **New Location** button. The **New Package** dialog will appear (Figure 47).
3. Enter the **Name**, **Description** and **Prefix** for the new package.
4. Click **OK** and a new package will be listed in the location.

### 3.3.3.2 Modifying Attributes

![Attributes Dialog](image)

**Figure 48 -- RequisitePro Modify Attributes Dialog**

To modify an attribute:

1. Select an element in the Containment tree > **MagicRQ** > **RequisitePro** > **New Requirement**. The **New Requirement Properties** dialog will open. The **Modify Attributes** button will be enabled if the selected element has additional stereotypes.
2. Click the **Modify Attributes** button. The **Attributes** dialog will open with the existing tag values of all stereotypes applied (Figure 48).
3. Select the attributes that you want to copy to the requirement.
4. Click **Save** and only the selected tags will be copied to the requirement.
3.3.4 Opening Associated Requirements

To open an element with only one association:

2. Either right-click and select Open Associated Requirement (RequisitePro) or click MagicRQ > RequisitePro > Open Associated Requirement.
3. The associated requirement will be highlighted in RequisitePro.

To open an element with more than one association:

2. Either right-click and select Open Associated Requirement (RequisitePro) or click MagicRQ > RequisitePro > Open Associated Requirement. The Open Associated Requirement dialog will open.
3. Select the element from the Element pane and the associated requirements will open in the Associated Requirement pane.
4. Select the associated requirement and click OK. The requirement will be highlighted in RequisitePro.

To open more than one element with at least one association:

2. Either right-click and select Open Associated Requirement (RequisitePro) or click MagicRQ > RequisitePro > Open Associated Requirement. The Open Associated Requirement dialog will open.
3. Select any element from the Element pane and the associated requirements will open in the Associated Requirement pane.
4. Select the associated requirement and click OK. The requirement will be highlighted in RequisitePro.
3.3.5 Synchronizing Data

[Refer to "Data Synchronization"]

3.3.6 Opening the View and Report Window

[Refer to "Opening the View and Report Window"]

3.3.7 Migration

If a MagicDraw project contains an association created in MagicRQ version 2.0 or lower, you can utilize the migration feature in order to make those associations compatible with MagicRQ 16.6.
To migrate associations from a previous version of MagicRQ:

2. A dialog will open to inform you that the migration process has been successfully completed. Click OK and all associations from the previous versions will be usable for MagicRQ 16.6.